archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-thrift / trunk / PKGBUILD
bloba9577084f027c334da91c430f079418ebbc612f1
1 # Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
3 pkgname=python-thrift
4 pkgver=0.18.1
5 pkgrel=2
6 pkgdesc='Python bindings for the Apache Thrift RPC system'
7 arch=(x86_64)
8 license=(Apache)
9 url='https://thrift.apache.org/'
10 depends=(python)
11 makedepends=(python-setuptools)
12 source=(thrift-$pkgver.zip::https://github.com/apache/thrift/archive/$pkgver.zip)
13 sha256sums=('5f803ff19acd6dc0e3857bbe46e1b01ba18526ea41342a36ab17ef18ede92017')
15 check() {
16   cd thrift-$pkgver/lib/py
17   # python setup.py test TODO: run tests
20 package() {
21   cd thrift-$pkgver/lib/py
22   python setup.py install --root="$pkgdir" --optimize=1