archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / reptyr / trunk / PKGBUILD
blobfa6bf8e9c4b5c036eb11d78dccd56441bacb574b
1 # Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
2 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
4 pkgname=reptyr
5 pkgver=0.9.0
6 pkgrel=1
7 pkgdesc='Utility for taking an existing running program and attaching it to a new terminal'
8 arch=('x86_64')
9 license=('BSD')
10 url="https://github.com/nelhage/reptyr"
11 depends=('glibc')
12 source=($pkgname-$pkgver.tar.gz::https://github.com/nelhage/$pkgname/tarball/$pkgname-$pkgver)
13 sha256sums=('8022af82c8f80299386e3200041980def5f8de38385a35d84b55b70aae9a9545')
15 prepare() {
16   cd "${srcdir}"/nelhage-$pkgname-*
18   sed -i 's|etc/bash_completion.d|usr/share/bash-completion/completions|' Makefile
21 build() {
22   cd "${srcdir}"/nelhage-$pkgname-*
24   make
27 package() {
28   cd "${srcdir}"/nelhage-$pkgname-*
30   make DESTDIR="${pkgdir}" PREFIX=/usr install
31   install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/reptyr/LICENSE