1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
5 _commit=0948e0c9d3d1b39ec40c7dfbd17b5328ed29c858
7 pkgdesc="Cantonese input for rime"
9 url="https://github.com/rime/rime-cantonese"
10 license=('CCPL:cc-by')
11 # dependency for reverse lookup
12 depends=('rime-cangjie' 'rime-emoji' 'rime-loengfan' 'rime-luna-pinyin' 'rime-stroke')
13 makedepends=('git' 'librime' 'rime-prelude' 'rime-essay')
14 source=("git+https://github.com/rime/rime-cantonese.git#commit=$_commit")
20 for _f in $(pacman -Qql rime-prelude rime-essay | grep -v "/$"); do ln -sf $_f; done
25 for _s in $(ls *.schema.yaml); do rime_deployer --compile $_s; done
30 find . -type l -delete
32 install -Dm644 *.txt *.yaml -t "$pkgdir"/usr/share/rime-data/
33 install -Dm644 build/* -t "$pkgdir"/usr/share/rime-data/build/
34 install -Dm644 opencc/* -t "$pkgdir"/usr/share/rime-data/opencc/