archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / rt-tests / trunk / PKGBUILD
blob2945847a0b8250fdd7b0e911adb58dedd55d9a9f
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Joakim Hernberg <jhernberg at alchemy dot lu>
4 pkgname=rt-tests
5 pkgver=2.5
6 pkgrel=2
7 pkgdesc="A collection of latency testing tools for the linux(-rt) kernel"
8 arch=(x86_64)
9 url="https://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git/about/"
10 license=(GPL2)
11 groups=(realtime)
12 depends=(glibc)
13 makedepends=(numactl python)
14 optdepends=(
15   'bash: for determine_maximum_mpps.sh'
16   'numactl: for cyclictest, oslat and signaltest'
17   'python: for get_cyclictest_snapshot and hwlatdetect'
19 source=(https://git.kernel.org/pub/scm/utils/$pkgname/$pkgname.git/snapshot/$pkgname-$pkgver.tar.gz)
20 sha512sums=('137ee2a0d3417843d7211fc3cb203d61ca528e0b2bd70ad9931e54324f600a73c4628f9c6cbe87d2df216eb26050e042d820c0bb65421bf3482c8bcb4fc657e3')
21 b2sums=('d59174d509588439fb86814158338dba6623b1b1c06d9607d30a3553b3604b83e8ae3b74d54420974ea6459a0eedfefef4b0e523a1422570e327ef3574ebd91a')
23 build() {
24   export PYLIB=$(python -c 'import distutils.sysconfig;  print(distutils.sysconfig.get_python_lib())')
25   make -C $pkgname-$pkgver
28 package() {
29   make prefix=/usr DESTDIR="$pkgdir" install -C $pkgname-$pkgver
30   install -vDm 644 $pkgname-$pkgver/{MAINTAINERS,README.markdown} -t "$pkgdir/usr/share/doc/$pkgname/"