1 # Maintainer: Bruno Pagani <archange@archlinux.org>
2 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 # Contributor: Gaetan Bisson <bisson@archlinux.org>
4 # Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
5 # Contributor: Ronald van Haren <ronald.archlinux.org>
6 # Contributor: tobias <tobias@archlinux.org>
7 # Contributor: Ben <ben@benmazer.net>
12 pkgdesc="Desktop publishing software"
14 url="https://www.scribus.net/"
16 depends=(cairo fontconfig freetype2 harfbuzz-icu
17 hunspell lcms2 libcdr libcups libfreehand libicuuc.so libjpeg libmspub
18 libpagemaker libpng libqxp librevenge libtiff libvisio libxml2 libzmf
19 openscenegraph openssl podofo poppler python3 qt5-base zlib) #graphicsmagick
20 makedepends=(cmake mesa qt5-tools)
21 optdepends=('tk: scripts based on tkinter'
22 'hyphen-lang: hyphenation patterns for desired languages')
24 source=("https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.asc}
25 $pkgname-poppler-22.02.0.patch::https://github.com/scribusproject/scribus/commit/85c0dff3422f.patch
26 $pkgname-poppler-22.02.0-fixup.patch::https://github.com/scribusproject/scribus/commit/f75c1613db67.patch
27 $pkgname-poppler-22.03.0.patch::https://github.com/scribusproject/scribus/commit/f19410ac3b27.patch
28 $pkgname-poppler-22.04.0.patch::https://github.com/scribusproject/scribus/commit/f2237b8f0b5c.patch
29 scribus-1.5.8-poppler-22.09.0.patch)
30 sha256sums=('47816e8fcf6d05788ff16aa4499f97ff22431c777a7789149b0a88b451e16b74'
32 '718ae9c882889b56919ab9718185b915a75e75e193a028539722b537f528c3dd'
33 '2b57c0c6dbc93037b83e392d4721523efbccd8af1fe6fc11a26f1d2933b14a85'
34 '986717d7c99a418d765e6b3d8b37165067548e62b6febb9c31f8831689f3540e'
35 '1649ca7476fc2f548b64e72773aa94933a3993f3fd2cbb54a30486dc49575816'
36 'd1712c200f7be2eb4f791cc046379747af39a1f9a262a090ae2de990b939b9b3')
37 validpgpkeys=(5086B8D68E70FDDF4C40045AEF7B95E7F60166DA # Peter Linnell <plinnell@scribus.net>
38 757F5E9B13DD648887AD50092D47C099E782504E # The Scribus Team (www.scribus.net) <the_scribus_team@scribus.net>
39 6558BE84D27273A438A151198BEA48118AEBEE64) # Craig Bradney <cbradney@zipworld.com.au>
42 cd ${pkgname}-${pkgver}
43 patch -Np1 -i ../$pkgname-poppler-22.02.0.patch
44 patch -Np1 -i ../$pkgname-poppler-22.02.0-fixup.patch
45 patch -Np1 -i ../$pkgname-poppler-22.03.0.patch
46 patch -Np1 -i ../$pkgname-poppler-22.04.0.patch
47 patch -Np1 -i ../scribus-1.5.8-poppler-22.09.0.patch
51 cmake -B build -S ${pkgname}-${pkgver} \
52 -DCMAKE_INSTALL_PREFIX=/usr \
53 -DCMAKE_BUILD_TYPE=None \
54 -DCMAKE_SKIP_RPATH=ON \
58 -DWANT_GRAPHICSMAGICK=ON
63 make -C build DESTDIR="${pkgdir}" install
65 cd ${pkgname}-${pkgver}
67 install -Dm644 scribus.desktop -t "${pkgdir}"/usr/share/applications
69 for i in 16x16 32x32 128x128 256x256 512x512 1024x1024
71 install -Dm644 resources/iconsets/artwork/icon_${i}.png "${pkgdir}"/usr/share/icons/hicolor/${i}/apps/scribus.png
75 rm -rf "${pkgdir}"/usr/share/scribus/dicts/hyph
76 ln -sf /usr/share/hyphen "${pkgdir}"/usr/share/scribus/dicts/hyph