1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: mutantmonkey <aur@mutantmonkey.in>
7 pkgdesc="Spice agent for Linux guests"
9 url="https://www.spice-space.org/"
11 depends=('alsa-lib' 'dbus' 'glib2' 'gtk3' 'libdrm' 'libpciaccess' 'libxfixes' 'libxinerama' 'libxrandr' 'systemd')
12 makedepends=('spice-protocol' 'git')
13 checkdepends=('procps-ng')
14 backup=('etc/conf.d/spice-vdagentd')
15 source=("https://www.spice-space.org/download/releases/$pkgname-$pkgver.tar.bz2")
16 sha256sums=('93b0d15aca4762cc7d379b179a7101149dbaed62b72112fffb2b3e90b11687a0')
20 sed -i 's|/etc/sysconfig/spice-vdagentd|/etc/conf.d/spice-vdagentd|
21 s|/usr/sbin/spice-vdagentd|/usr/bin/spice-vdagentd|' data/spice-vdagentd.service
22 sed -i 's|/etc/sysconfig/spice-vdagentd|/etc/conf.d/spice-vdagentd|' data/spice-vdagentd.1.in
27 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin \
28 --with-session-info=systemd --with-init-script=systemd
33 make -C $pkgname-$pkgver check || : # test-session-info fails
38 make DESTDIR="$pkgdir" install
40 install -dm755 "$pkgdir/etc/conf.d/"
41 echo 'SPICE_VDAGENTD_EXTRA_ARGS=""' > "$pkgdir/etc/conf.d/spice-vdagentd"