archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / sshfs / repos / community-x86_64 / PKGBUILD
blobae5984a8944c0bb7b7c270e69625d03b4e839a23
1 # Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
2 # Contributor: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
5 pkgname=sshfs
6 pkgver=3.7.3
7 pkgrel=1
8 pkgdesc="FUSE client based on the SSH File Transfer Protocol"
9 arch=('x86_64')
10 url="https://github.com/libfuse/sshfs"
11 license=(GPL)
12 depends=(fuse3 glib2 openssh)
13 makedepends=('meson' 'python-docutils')
14 source=(https://github.com/libfuse/sshfs/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz{,.asc})
15 sha256sums=('5218ce7bdd2ce0a34137a0d7798e0f6d09f0e6d21b1e98ee730a18b0699c2e99'
16             'SKIP')
17 validpgpkeys=('ED31791B2C5C1613AF388B8AD113FCAC3C4E599F') # Nikolaus Rath <Nikolaus@rath.org>
19 prepare() {
20   cd $pkgname-$pkgver
22   rm -rf build
23   mkdir build
24   cd build
25   arch-meson ..
28 build() {
29   cd $pkgname-$pkgver/build
30   ninja
33 package() {
34   cd $pkgname-$pkgver/build
36   DESTDIR="$pkgdir" ninja install