archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / webkit2-sharp / trunk / PKGBUILD
blobbf49f4e6616ba004758cdcc8c21b716328cd6b68
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgname=webkit2-sharp
4 pkgver=2.10.9
5 pkgrel=3
6 pkgdesc="C Sharp bindings for WebKit 2 with GTK+ 3"
7 arch=(x86_64)
8 url="https://github.com/hbons/webkit2-sharp"
9 license=(MIT)
10 depends=(gtk-sharp-3 webkit2gtk)
11 makedepends=(git libxslt)
12 _commit=dec1e10876f3bbda621f635937c23ac486cd6e05  # master
13 source=("git+https://github.com/hbons/webkit2-sharp#commit=$_commit")
14 sha256sums=('SKIP')
16 build() {
17   cd $pkgname
18   ./autogen.sh --prefix=/usr
19   make -j1
22 package() {
23   cd $pkgname
24   make DESTDIR="$pkgdir" install
25   install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"