1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Jens Adam <jra@byte.cx>
3 # Contributor: Arch3y <arch3y[at]archstrike[dot]org>
8 pkgdesc='Fast network scanner designed for Internet-wide network surveys'
12 depends=('gmp' 'hiredis' 'json-c' 'libpcap' 'libmongoc')
13 makedepends=('byacc' 'cmake' 'gengetopt' 'pkg-config')
14 backup=('etc/zmap/blacklist.conf' 'etc/zmap/zmap.conf')
15 source=(${pkgname}-${pkgver}.tar.gz::https://github.com/zmap/zmap/archive/v${pkgver}.tar.gz)
16 sha512sums=('9d62dceff77fa20ff5945516b0766340366175947130bb844f19c11dac7676e658bcdedd6be29ffc945706aa3cdc0e4ac207bd127b618592769a4d3e75892857')
19 cd ${pkgname}-${pkgver}
20 cmake -DWITH_JSON=ON -DWITH_REDIS=ON -DWITH_MONGO=ON
25 cd ${pkgname}-${pkgver}
26 install -Dm 755 src/{zmap,ztee,zblacklist} -t "${pkgdir}/usr/bin"
27 install -Dm 644 src/*.1 -t "${pkgdir}/usr/share/man/man1"
28 install -Dm 644 conf/* -t "${pkgdir}/etc/zmap"
29 install -Dm 644 AUTHORS CHANGELOG.md INSTALL.md README.md \
30 -t "${pkgdir}/usr/share/doc/zmap"
31 cp -a examples "${pkgdir}/usr/share/doc/zmap"