2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
8 # This is the debhelper compatibility version to use.
10 export PERL_MM_USE_DEFAULT
=1
16 TMP
=$(CURDIR
)/debian
/tmp
21 $(PERL
) Makefile.PL verbose INSTALLDIRS
=vendor
31 dh_clean build-stamp install-stamp
33 install: build install-stamp
42 $(MAKE
) pure_install DESTDIR
=$(TMP
) PREFIX
=/usr
44 find
$(TMP
) -name .packlist
-exec
rm '{}' \
;
45 find
$(TMP
) -depth
-type d
-empty
-exec rmdir
'{}' \
;
47 dh_install
--sourcedir
=$(TMP
) --fail-missing
52 # Nothing to do here, yet.
53 binary-indep
: build
install
72 binary
: binary-indep binary-arch
73 .PHONY
: build
clean binary-indep binary-arch binary
install configure