Tell the kernel we're doing sequential reads.
[MogileFS-Server.git] / debian / rules
blob41c724e3b5d525a2aad9888b0af0195408916ddd
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
8 # This is the debhelper compatibility version to use.
9 # export DH_COMPAT=4
10 export PERL_MM_USE_DEFAULT=1
12 ifndef PERL
13 PERL = /usr/bin/perl
14 endif
16 TMP =$(CURDIR)/debian/tmp
18 build: build-stamp
19 build-stamp:
20 dh_testdir
21 $(PERL) Makefile.PL verbose INSTALLDIRS=vendor
22 $(MAKE)
24 touch build-stamp
26 clean:
27 dh_testdir
28 dh_testroot
30 -$(MAKE) distclean
31 dh_clean build-stamp install-stamp
33 install: build install-stamp
34 install-stamp:
35 dh_testdir
36 dh_testroot
37 dh_clean -k
39 dh_installdirs -A
41 # $(MAKE) test
42 $(MAKE) pure_install DESTDIR=$(TMP) PREFIX=/usr
44 find $(TMP) -name .packlist -exec rm '{}' \;
45 find $(TMP) -depth -type d -empty -exec rmdir '{}' \;
47 dh_install --sourcedir=$(TMP) --fail-missing
49 touch install-stamp
51 binary-arch:
52 # Nothing to do here, yet.
53 binary-indep: build install
54 dh_testdir
55 dh_testroot
56 dh_installexamples
57 dh_installdocs
58 dh_installman
59 dh_installdebconf
60 dh_installinit
61 dh_installchangelogs
62 dh_link
63 dh_strip
64 dh_compress
65 dh_fixperms
66 dh_installdeb
67 dh_perl
68 dh_gencontrol
69 dh_md5sums
70 dh_builddeb
72 binary: binary-indep binary-arch
73 .PHONY: build clean binary-indep binary-arch binary install configure