ThirdParty packages: Fix typos for some .csh files. Add some comments in the etc...
[OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / ParMetis-3.1.1.spec
blob3f8725bf03b448ccb8b2480a23b2eb13d25dbed1
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #-------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for ParMetis-3.1.1
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath %{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
57 # regenerate the RPM.
59 %define _prefix %{_WM_THIRD_PARTY_DIR}
61 %define name ParMetis
62 %define release %{_WM_OPTIONS}
63 %define version 3.1.1
65 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
68 Summary: ParMetis
69 License: Unkown
70 Name: %{name}
71 Version: %{version}
72 Release: %{release}
73 URL: http://glaros.dtc.umn.edu/gkhome/fetch/sw/parmetis
74 Source: %url/%{name}-%{version}.tar.gz
75 Prefix: %{_prefix}
76 Group: Development/Tools
77 Patch0: ParMetis-3.1.1.patch_darwin
78 Patch1: ParMetis-3.1.1.patch
80 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
82 %description
83 %{summary}
85 %prep
86 %setup -q
88 %ifos darwin
89 %patch0 -p1
90 %else
91 %patch1 -p1
92 %endif
94 %build
95 [ -n "$WM_CC" ] && export CC="$WM_CC"
96 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
97 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
98 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
99 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
101 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
102 make -j $WM_NCOMPPROCS
105 %install
106 # Manual installation
107 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include/ParMETISLib
108 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/lib
110 cp *.h $RPM_BUILD_ROOT/%{_installPrefix}/include
111 cp ParMETISLib/*.h $RPM_BUILD_ROOT/%{_installPrefix}/include/ParMETISLib
113 cp METISLib/libmetis-parmetis.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
114 cp ParMETISLib/libparmetis.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
116 # Creation of OpenFOAM specific .csh and .sh files"
118 echo ""
119 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
120 echo ""
122 # Generate package specific .sh file for OpenFOAM
124 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
125 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
126 # Load %{name}-%{version} libraries and binaries if available
127 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
129 export PARMETIS_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
130 export PARMETIS_BIN_DIR=\$PARMETIS_DIR/bin
131 export PARMETIS_LIB_DIR=\$PARMETIS_DIR/lib
132 export PARMETIS_INCLUDE_DIR=\$PARMETIS_DIR/include
134 # Enable access to the runtime package applications and libraries
135 [ -d \$PARMETIS_BIN_DIR ] && _foamAddPath \$PARMETIS_BIN_DIR
136 [ -d \$PARMETIS_LIB_DIR ] && _foamAddLib \$PARMETIS_LIB_DIR
138 DOT_SH_EOF
141 # Generate package specific .csh file for OpenFOAM
143 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
144 # Load %{name}-%{version} libraries and binaries if available
145 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
146 setenv PARMETIS_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
147 setenv PARMETIS_BIN_DIR \$PARMETIS_DIR/bin
148 setenv PARMETIS_LIB_DIR \$PARMETIS_DIR/lib
149 setenv PARMETIS_INCLUDE_DIR \$PARMETIS_DIR/include
151 if ( -e \$PARMETIS_BIN_DIR ) then
152 _foamAddPath \$PARMETIS_BIN_DIR
153 endif
155 if ( -e \$PARMETIS_LIB_DIR ) then
156 _foamAddLib \$PARMETIS_LIB_DIR
157 endif
158 DOT_CSH_EOF
160 %clean
161 rm -rf %{buildroot}
163 %Files
164 %defattr(-,root,root)
165 %{_installPrefix}/*