ThirdParty packages: Fix typos for some .csh files. Add some comments in the etc...
[OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / mesquite-2.1.2.spec
blob970fe791ff6d8ef847cf52be68ea41d5ba7def65
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #-------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for mesquite-2.1.2
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath %{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
57 # regenerate the RPM.
59 %define _prefix %{_WM_THIRD_PARTY_DIR}
61 %define name mesquite
62 %define release %{_WM_OPTIONS}
63 %define version 2.1.2
65 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
68 Summary: mesquite
69 License: Unkown
70 Name: %{name}
71 Version: %{version}
72 Release: %{release}
73 URL: http://software.sandia.gov/~jakraft
74 Source: %url/%{name}-%{version}.tar.gz
75 Prefix: %{_prefix}
76 Group: Development/Tools
78 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
80 %description
81 %{summary}
83 %prep
84 %setup -q
86 %build
87 # export WM settings in a form that GNU configure recognizes
88 [ -n "$WM_CC" ] && export CC="$WM_CC"
89 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
90 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
91 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
92 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
94 ./configure \
95 --prefix=%{_installPrefix} \
96 --enable-release \
97 --disable-debug-assertions \
98 --disable-igeom \
99 --disable-imesh \
100 --disable-irel \
101 --enable-shared \
102 --without-cppunit \
103 --enable-trap-fpe \
104 --disable-function-timers
106 # Remove the file include/Mesquite_all_headers.hpp
107 # This file will be regenerated during the compilation process
108 [ -e include/Mesquite_all_headers.hpp ] && rm -f include/Mesquite_all_headers.hpp
110 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
111 make -j $WM_NCOMPPROCS
113 %install
114 make install prefix=$RPM_BUILD_ROOT%{_installPrefix}
116 # Creation of OpenFOAM specific .csh and .sh files"
118 echo ""
119 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
120 echo ""
122 # Generate package specific .sh file for OpenFOAM
124 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
125 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
126 # Load %{name}-%{version} libraries and binaries if available
127 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
129 export MESQUITE_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
130 export MESQUITE_BIN_DIR=\$MESQUITE_DIR/bin
131 export MESQUITE_LIB_DIR=\$MESQUITE_DIR/lib
132 export MESQUITE_INCLUDE_DIR=\$MESQUITE_DIR/include
134 # Enable access to the package runtime applications and libraries
135 [ -d \$MESQUITE_BIN_DIR ] && _foamAddPath \$MESQUITE_BIN_DIR
136 [ -d \$MESQUITE_LIB_DIR ] && _foamAddLib \$MESQUITE_LIB_DIR
137 DOT_SH_EOF
140 # Generate package specific .csh file for OpenFOAM
142 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
143 # Load %{name}-%{version} libraries and binaries if available
144 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
145 setenv MESQUITE_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
146 setenv MESQUITE_BIN_DIR \$MESQUITE_DIR/bin
147 setenv MESQUITE_LIB_DIR \$MESQUITE_DIR/lib
148 setenv MESQUITE_INCLUDE_DIR \$MESQUITE_DIR/include
150 if ( -e \$MESQUITE_BIN_DIR ) then
151 _foamAddPath \$MESQUITE_BIN_DIR
152 endif
154 if ( -e \$MESQUITE_LIB_DIR ) then
155 _foamAddLib \$MESQUITE_LIB_DIR
156 endif
157 DOT_CSH_EOF
159 %clean
160 rm -rf %{buildroot}
162 %files
163 %defattr(-,root,root)
164 %{_installPrefix}