1 #------------------------------------------------------------------------------
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
5 # \\ / A nd | Copyright held by original author
7 #-------------------------------------------------------------------------------
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
26 # RPM spec file for mpc-0.8.2
29 # RPM spec file for creating a relocatable RPM
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath
%{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 %define _prefix
%{_WM_THIRD_PARTY_DIR}
62 %define release
%{_WM_OPTIONS}
65 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
73 URL: http
://www.multiprecision.org
/mpc
/download
/
74 Source: %url/%{name}-%{version}.tar.gz
76 Group: Development
/Tools
79 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
88 # export WM settings in a form that GNU configure recognizes
89 [ -n "$WM_CC"
] && export CC
="$WM_CC"
90 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
91 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
92 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
93 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
96 MPFR_VERSION
=mpfr
-3.0.0
99 --prefix
=%{_installPrefix} \
100 --with
-gmp
=$WM_THIRD_PARTY_DIR
/packages
/$GMP_VERSION
/platforms
/$WM_OPTIONS \
101 --with
-mpfr
=$WM_THIRD_PARTY_DIR
/packages
/$MPFR_VERSION
/platforms
/$WM_OPTIONS
103 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
104 make -j $WM_NCOMPPROCS
107 make install prefix
=$RPM_BUILD_ROOT
%{_installPrefix}
109 # Creation of OpenFOAM specific .csh and .sh files"
112 echo "Generating OpenFOAM specific .csh and .sh files
for the package
%{name}-%{version}"
115 # Generate package specific .sh file for OpenFOAM
117 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
118 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
119 # Load %{name}-%{version} libraries and binaries if available
120 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
122 export MPC_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
124 [ -d \$MPC_DIR
/lib
] && _foamAddLib \$MPC_DIR
/lib
126 # Enable access to the package applications if present
127 [ -d \$MPC_DIR
/bin
] && _foamAddPath \$MPC_DIR
/bin
131 # Generate package specific .csh file for OpenFOAM
133 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
134 # Load %{name}-%{version} libraries and binaries if available
135 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
136 setenv MPC_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
138 if ( -e \$MPC_DIR
/lib
) then
139 _foamAddLib \$MPC_DIR
/lib
142 if ( -e \$MPC_DIR
/bin
) then
143 _foamAddPath \$MPC_DIR
/bin
151 %defattr(-,root
,root
)
152 %{_installPrefix}/etc
153 %{_installPrefix}/include
154 %{_installPrefix}/lib
155 %{_installPrefix}/share