1 #------------------------------------------------------------------------------
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
5 # \\ / A nd | Copyright held by original author
7 #-------------------------------------------------------------------------------
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
26 # RPM spec file for openmpi-1.5
29 # RPM spec file for creating a relocatable RPM
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath
%{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 %define _prefix
%{_WM_THIRD_PARTY_DIR}
62 %define release
%{_WM_OPTIONS}
65 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
73 URL: http
://www.open
-mpi.org
/software
/ompi
/v1.5
/downloads
74 Source: %url/%{name}-%{version}.tar.gz
76 Group: Development
/Tools
79 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
88 # export WM settings in a form that GNU configure recognizes
89 [ -n "$WM_CC"
] && export CC
="$WM_CC"
90 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
91 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
92 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
93 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
96 # enable GridEngine if it appears to be in use
99 mpiWith
="$mpiWith
--with
-sge"
103 # if [ -d /usr/local/ofed -a -d /usr/local/ofed/lib64 ]
105 # mpiWith="$mpiWith --with-openib=/usr/local/ofed"
106 # mpiWith="$mpiWith --with-openib-libdir=/usr/local/ofed/lib64"
110 --prefix
=$RPM_BUILD_ROOT
%{_installPrefix} \
111 --disable
-mpirun
-prefix
-by
-default \
112 --disable
-orterun
-prefix
-by
-default \
113 --enable-shared
--disable
-static \
117 --disable
-mpi
-profile \
121 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
122 make -j $WM_NCOMPPROCS
125 make install prefix
=$RPM_BUILD_ROOT
%{_installPrefix}
127 # Creation of OpenFOAM specific .csh and .sh files"
130 echo "Generating OpenFOAM specific .csh and .sh files
for the package
%{name}-%{version}"
133 # Generate package specific .sh file for OpenFOAM
135 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
136 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
137 # Load %{name}-%{version} libraries and binaries
138 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
139 export OPENMPI_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/openmpi
-1.5/platforms
/\$WM_OPTIONS
140 export OPENMPI_BIN_DIR
=\$OPENMPI_DIR
/bin
141 export OPENMPI_LIB_DIR
=\$OPENMPI_DIR
/lib
143 # Enable access to the package runtime applications and libraries
144 [ -d \$OPENMPI_BIN_DIR
] && _foamAddPath \$OPENMPI_BIN_DIR
145 [ -d \$OPENMPI_LIB_DIR
] && _foamAddLib \$OPENMPI_LIB_DIR
147 export MPI_HOME
=\$OPENMPI_DIR
148 export MPI_ARCH_PATH
=\$MPI_HOME
149 export OPAL_PREFIX
=\$MPI_ARCH_PATH
151 # We initialize the rest of the environment using mpicc --showme:
152 export OPENMPI_INCLUDE_DIR
="\`mpicc
--showme
:incdirs\`"
153 export OPENMPI_COMPILE_FLAGS
="\`mpicc
--showme
:compile\`"
154 export OPENMPI_LINK_FLAGS
="\`mpicc
--showme
:link\`"
156 # Set the OpenFOAM compilation flags
157 export PINC
=\$OPENMPI_COMPILE_FLAGS
158 export PLIBS
=\$OPENMPI_LINK_FLAGS
161 if [ "\$FOAM_VERBOSE"
-a "\$PS1"
]
163 echo "Using system installed OpenMPI
:"
164 echo " OPENMPI_BIN_DIR
: \$OPENMPI_BIN_DIR"
165 echo " OPENMPI_LIB_DIR
: \$OPENMPI_LIB_DIR"
166 echo " OPENMPI_INCLUDE_DIR
: \$OPENMPI_INCLUDE_DIR"
167 echo " OPENMPI_COMPILE_FLAGS
: \$OPENMPI_COMPILE_FLAGS"
168 echo " OPENMPI_LINK_FLAGS
: \$OPENMPI_LINK_FLAGS"
170 echo " MPI_HOME
: \$MPI_HOME"
171 echo " MPI_ARCH_PATH
: \$MPI_ARCH_PATH"
172 echo " OPAL_PREFIX
: \$OPAL_PREFIX"
173 echo " PINC
: \$PINC"
174 echo " PLIBS
: \$PLIBS"
179 # Generate package specific .csh file for OpenFOAM
181 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
182 # Load %{name}-%{version} libraries and binaries
183 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
184 setenv OPENMPI_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
185 setenv OPENMPI_BIN_DIR \$OPENMPI_DIR
/bin
186 setenv OPENMPI_LIB_DIR \$OPENMPI_DIR
/lib
188 # Enable access to the package runtime applications and libraries
189 if ( -e \$OPENMPI_BIN_DIR
) then
190 _foamAddPath \$OPENMPI_BIN_DIR
193 if ( -e \$OPENMPI_LIB_DIR
) then
194 _foamAddLib \$OPENMPI_LIB_DIR
197 setenv MPI_HOME \$OPENMPI_DIR
198 setenv MPI_ARCH_PATH \$MPI_HOME
199 setenv OPAL_PREFIX \$MPI_ARCH_PATH
201 # We initialize the rest of the environment using mpicc --showme:
202 setenv OPENMPI_INCLUDE_DIR "\`mpicc
--showme
:incdirs\`"
203 setenv OPENMPI_COMPILE_FLAGS "\`mpicc
--showme
:compile\`"
204 setenv OPENMPI_LINK_FLAGS "\`mpicc
--showme
:link\`"
206 # Set the OpenFOAM compilation flags
207 setenv PINC \$OPENMPI_COMPILE_FLAGS
208 setenv PLIBS \$OPENMPI_LINK_FLAGS
211 if (\$?FOAM_VERBOSE
&& \$?prompt
) then
212 echo "Using system installed OpenMPI
:"
213 echo " OPENMPI_BIN_DIR
: \$OPENMPI_BIN_DIR"
214 echo " OPENMPI_LIB_DIR
: \$OPENMPI_LIB_DIR"
215 echo " OPENMPI_INCLUDE_DIR
: \$OPENMPI_INCLUDE_DIR"
216 echo " OPENMPI_COMPILE_FLAGS
: \$OPENMPI_COMPILE_FLAGS"
217 echo " OPENMPI_LINK_FLAGS
: \$OPENMPI_LINK_FLAGS"
219 echo " MPI_HOME
: \$MPI_HOME"
220 echo " MPI_ARCH_PATH
: \$MPI_ARCH_PATH"
221 echo " OPAL_PREFIX
: \$OPAL_PREFIX"
222 echo " PINC
: \$PINC"
223 echo " PLIBS
: \$PLIBS"
231 %defattr(-,root
,root
)