1 #------------------------------------------------------------------------------
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
5 # \\ / A nd | Copyright held by original author
7 #-------------------------------------------------------------------------------
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
26 # RPM spec file for qt-everywhere-opensource-src-4.7.0
29 # RPM spec file for creating a relocatable RPM
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath
%{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 %define _prefix
%{_WM_THIRD_PARTY_DIR}
61 %define name qt
-everywhere
-opensource
-src
62 %define release
%{_WM_OPTIONS}
65 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
67 %define _unpackaged_files_terminate_build
0
68 %define _missing_doc_files_terminate_build
0
70 BuildRoot: %{buildroot}
71 Summary: qt
-everywhere
-opensource
-src
76 URL: http
://get.qt.nokia.com
/qt
/source/qt
-everywhere
-opensource
-src
77 Source: %url/%{name}-%{version}.tar.gz
79 Group: Development
/Tools
82 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
91 # export WM settings in a form that GNU configure recognizes
92 [ -n "$WM_CC"
] && export CC
="$WM_CC"
93 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
94 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
95 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
96 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
99 -opensource
--confirm
-license
=yes \
100 --prefix
=%{_installPrefix}
102 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
103 make -j $WM_NCOMPPROCS
106 # make install INSTALL_ROOT=$RPM_BUILD_ROOT%{_installPrefix}
107 make install INSTALL_ROOT
=$RPM_BUILD_ROOT
109 # Creation of OpenFOAM specific .csh and .sh files"
112 echo "Generating OpenFOAM specific .csh and .sh files
for the package
%{name}-%{version}"
115 # Generate package specific .sh file for OpenFOAM
117 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
118 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
119 # Load %{name}-%{version} libraries and binaries if available
120 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
122 export QT_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
123 export QT_BIN_DIR
=\$QT_DIR
/bin
125 # Enable access to the runtime package applications
126 [ -d \$QT_BIN_DIR
] && _foamAddPath \$QT_BIN_DIR
130 # Generate package specific .csh file for OpenFOAM
132 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
133 # Load %{name}-%{version} libraries and binaries if available
134 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
135 setenv QT_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
136 setenv QT_BIN_DIR \$QT_DIR
/bin
138 if ( -e \$QT_BIN_DIR
) then
139 _foamAddPath \$QT_BIN_DIR
147 %defattr(-,root
,root
)
148 %{_installPrefix}/bin
149 %{_installPrefix}/etc
150 %{_installPrefix}/lib
151 %{_installPrefix}/imports
152 %{_installPrefix}/include
153 %{_installPrefix}/mkspecs
154 %{_installPrefix}/plugins
155 %{_installPrefix}/phrasebooks
156 %{_installPrefix}/q3porting.xml
157 %{_installPrefix}/translations