ThirdParty packages: Fix typos for some .csh files. Add some comments in the etc...
[OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / scotch-5.1.10b.spec
blobfb7215e32d36904d3044833b86081b5d18281f41
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #-------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for scotch-5.1.10b
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath %{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
57 # regenerate the RPM.
59 %define _prefix %{_WM_THIRD_PARTY_DIR}
61 %define name scotch
62 %define release %{_WM_OPTIONS}
63 %define version 5.1.10b
65 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
68 Summary: scotch
69 License: Unkown
70 Name: %{name}
71 Version: %{version}
72 Release: %{release}
73 URL: https://gforge.inria.fr/frs/download.php/27583
74 Source: %url/%{name}-%{version}.tar.gz
75 Prefix: %{_prefix}
76 Group: Development/Tools
77 Patch0: scotch-5.1.10b_patch_0
79 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
81 %description
82 %{summary}
84 %prep
85 %setup -q -n %{name}_%{version}
87 %patch0 -p1
89 %build
90 # export WM settings in a form that GNU configure recognizes
91 [ -n "$WM_CC" ] && export CC="$WM_CC"
92 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
93 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
94 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
95 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
97 cd src
98 # Here, unfortunately, some hand tweaking might be necessary if your system is not running Linux or MacOS X
99 %ifos darwin
100 ln -s Make.inc/Makefile.inc.i686_mac_darwin10.shlib Makefile.inc
101 %else
102 ln -s Make.inc/Makefile.inc.i686_pc_linux2.shlib Makefile.inc
103 %endif
105 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
106 make -j $WM_NCOMPPROCS scotch
107 make -j $WM_NCOMPPROCS ptscotch
109 %install
110 cd src
111 mkdir -p $RPM_BUILD_ROOT%{_installPrefix}
112 make install prefix=$RPM_BUILD_ROOT%{_installPrefix}
114 # Creation of OpenFOAM specific .csh and .sh files"
116 echo ""
117 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
118 echo ""
120 # Generate package specific .sh file for OpenFOAM
122 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
123 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
124 # Load %{name}-%{version} libraries and binaries if available
125 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
127 export SCOTCH_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
128 export SCOTCH_BIN_DIR=\$SCOTCH_DIR/bin
129 export SCOTCH_LIB_DIR=\$SCOTCH_DIR/lib
130 export SCOTCH_INCLUDE_DIR=\$SCOTCH_DIR/include
132 # Enable access to the runtime package applications and libraries
133 [ -d \$SCOTCH_BIN_DIR ] && _foamAddPath \$SCOTCH_BIN_DIR
134 [ -d \$SCOTCH_LIB_DIR ] && _foamAddLib \$SCOTCH_LIB_DIR
135 DOT_SH_EOF
138 # Generate package specific .csh file for OpenFOAM
140 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
141 # Load %{name}-%{version} libraries and binaries if available
142 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
143 setenv SCOTCH_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
144 setenv SCOTCH_BIN_DIR \$SCOTCH_DIR/bin
145 setenv SCOTCH_LIB_DIR \$SCOTCH_DIR/lib
146 setenv SCOTCH_INCLUDE_DIR \$SCOTCH_DIR/include
148 if ( -e \$SCOTCH_BIN_DIR ) then
149 _foamAddPath \$SCOTCH_BIN_DIR
150 endif
152 if ( -e \$SCOTCH_LIB_DIR ) then
153 _foamAddLib \$SCOTCH_LIB_DIR
154 endif
155 DOT_CSH_EOF
157 %clean
158 rm -rf %{buildroot}
160 %files
161 %defattr(-,root,root)
162 %{_installPrefix}/*