ThirdParty: adjustments to path of generated .tgz files
[OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / metis-5.0pre2.spec
blob6f98ce07f77fb6614848e200b984fc302be72ebf
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for metis-5.0pre2
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath %{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
57 # regenerate the RPM.
59 %define _prefix %{_WM_THIRD_PARTY_DIR}
61 %define name metis
62 %define release %{_WM_OPTIONS}
63 %define version 5.0pre2
65 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
68 Summary: metis
69 License: Unkown
70 Name: %{name}
71 Version: %{version}
72 Release: %{release}
73 URL: http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis
74 Source: %url/%{name}-%{version}.tar.gz
75 Prefix: %{_prefix}
76 Group: Development/Tools
77 Patch0: metis-5.0pre2_patch_darwin
79 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
81 %description
82 %{summary}
84 %prep
85 %setup -q
87 %ifos darwin
88 %patch0 -p1
89 %endif
91 %build
92 [ -n "$WM_CC" ] && export CC="$WM_CC"
93 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
94 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
95 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
96 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
98 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
100 %ifos darwin
101 # The parameter -D_POSIX_C_SOURCE=200809 has a side effect on Mac OS X
102 (cd GKlib/trunk && make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC")
103 (cd libmetis && make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC")
104 %else
105 (cd GKlib/trunk && make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC -D_POSIX_C_SOURCE=200809")
106 (cd libmetis && make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC -D_POSIX_C_SOURCE=200809")
107 %endif
109 %install
110 # Manual installation
111 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include
112 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/lib
113 cp GKlib/builds/*/libGKlib.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
114 cp build/*/libmetis.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
115 cp include/metis.h $RPM_BUILD_ROOT/%{_installPrefix}/include
117 # Creation of OpenFOAM specific .csh and .sh files"
119 echo ""
120 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
121 echo ""
123 # Generate package specific .sh file for OpenFOAM
125 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
126 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
127 # Load %{name}-%{version} libraries and binaries if available
128 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
130 export METIS_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
131 export METIS_BIN_DIR=\$METIS_DIR/bin
132 export METIS_LIB_DIR=\$METIS_DIR/lib
133 export METIS_INCLUDE_DIR=\$METIS_DIR/include
135 # Enable access to the package runtime applications and libraries
136 [ -d \$METIS_BIN_DIR ] && _foamAddPath \$METIS_BIN_DIR
137 [ -d \$METIS_LIB_DIR ] && _foamAddLib \$METIS_LIB_DIR
139 DOT_SH_EOF
142 # Generate package specific .csh file for OpenFOAM
144 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
145 # Load %{name}-%{version} libraries and binaries if available
146 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
147 setenv METIS_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
148 setenv METIS_BIN_DIR \$METIS_DIR/bin
149 setenv METIS_LIB_DIR \$METIS_DIR/lib
150 setenv METIS_INCLUDE_DIR \$METIS_DIR/include
152 if ( -e \$METIS_BIN_DIR ) then
153 _foamAddPath \$METIS_BIN_DIR
154 endif
156 if ( -e \$METIS_LIB_DIR ) then
157 _foamAddLib \$METIS_LIB_DIR
158 endif
159 DOT_CSH_EOF
161 #finally, generate a .tgz file for systems where using rpm for installing packages
162 # as a non-root user might be a problem.
163 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
166 %clean
167 rm -rf %{buildroot}
169 %Files
170 %defattr(-,root,root)
171 %{_installPrefix}/*