1 #------------------------------------------------------------------------------
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
5 # \\ / A nd | Copyright held by original author
7 #------------------------------------------------------------------------------
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
26 # RPM spec file for m4-1.4.16
29 # RPM spec file for creating a relocatable RPM
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package
%{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath
%{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in thi file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
62 %define _prefix
%{_WM_THIRD_PARTY_DIR}
65 %define release
%{_WM_OPTIONS}
66 %define version
1.4.16
68 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
76 URL: http
://ftp.gnu.org
/gnu
/m4
77 Source: %url/%{name}-%{version}.tar.gz
79 Group: Development
/Tools
81 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
90 # export WM settings in a form that GNU configure recognizes
91 [ -n "$WM_CC"
] && export CC
="$WM_CC"
92 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
93 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
94 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
95 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
98 --prefix
=%{_installPrefix}
100 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
101 make -j $WM_NCOMPPROCS
104 make install DESTDIR
=$RPM_BUILD_ROOT
106 # Creation of OpenFOAM specific .csh and .sh files"
109 echo "Generating OpenFOAM specific .csh and .sh files
for the package
%{name}-%{version}"
112 # Generate package specific .sh file for OpenFOAM
114 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
115 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
116 # Load %{name}-%{version} libraries and binaries if available
117 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
119 export M4_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
121 [ -d \$M4_DIR
/lib
] && _foamAddLib \$M4_DIR
/lib
123 # Enable access to the package applications if present
124 [ -d \$M4_DIR
/bin
] && _foamAddPath \$M4_DIR
/bin
128 # Generate package specific .csh file for OpenFOAM
130 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
131 # Load %{name}-%{version} libraries and binaries if available
132 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
133 setenv M4_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
135 if ( -e \$M4_DIR
/lib
) then
136 _foamAddLib \$M4_DIR
/lib
139 if ( -e \$M4_DIR
/bin
) then
140 _foamAddPath \$M4_DIR
/bin
144 #finally, generate a .tgz file for systems where using rpm for installing packages
145 # as a non-root user might be a problem.
146 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
153 %defattr(-,root
,root
)