fixed writing out entries in advective bc
[OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / mpfr-3.0.0.spec
bloba7e993b3d05f6909f9b5800c6e163b519121a347
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for mpfr-3.0.0
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package %{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath %{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in thi file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
60 # regenerate the RPM.
62 %define _prefix %{_WM_THIRD_PARTY_DIR}
64 %define name mpfr
65 %define release %{_WM_OPTIONS}
66 %define version 3.0.0
68 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
71 Summary: mpfr
72 License: Unkown
73 Name: %{name}
74 Version: %{version}
75 Release: %{release}
76 URL: ftp://ftp.gnu.org/gnu/mpfr
77 Source: %url/%{name}-%{version}.tar.gz
78 Prefix: %{_prefix}
79 Group: Development/Tools
81 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
83 %description
84 %{summary}
86 %prep
87 %setup -q
89 %build
90 # export WM settings in a form that GNU configure recognizes
91 [ -n "$WM_CC" ] && export CC="$WM_CC"
92 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
93 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
94 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
95 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
97 GMP_VERSION=gmp-5.0.1
98 ./configure \
99 --prefix=%{_installPrefix} \
100 --with-gmp=$WM_THIRD_PARTY_DIR/packages/$GMP_VERSION/platforms/$WM_OPTIONS
102 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
103 make -j $WM_NCOMPPROCS
105 %install
106 make install DESTDIR=$RPM_BUILD_ROOT
109 # Creation of OpenFOAM specific .csh and .sh files"
111 echo ""
112 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
113 echo ""
115 # Generate package specific .sh file for OpenFOAM
117 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
118 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
119 # Load %{name}-%{version} libraries and binaries if available
120 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
122 export MPFR_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
124 [ -d \$MPFR_DIR/lib ] && _foamAddLib \$MPFR_DIR/lib
126 # Enable access to the package applications if present
127 [ -d \$MPFR_DIR/bin ] && _foamAddPath \$MPFR_DIR/bin
128 DOT_SH_EOF
131 # Generate package specific .csh file for OpenFOAM
133 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
134 # Load %{name}-%{version} libraries and binaries if available
135 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
136 setenv MPFR_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
138 if ( -e \$MPFR_DIR/lib ) then
139 _foamAddLib \$MPFR_DIR/lib
140 endif
142 if ( -e \$MPFR_DIR/bin ) then
143 _foamAddPath \$MPFR_DIR/bin
144 endif
145 DOT_CSH_EOF
147 #finally, generate a .tgz file for systems where using rpm for installing packages
148 # as a non-root user might be a problem.
149 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
152 %clean
153 rm -rf %{buildroot}
155 %files
156 %defattr(-,root,root)
157 %{_installPrefix}