1 # Maintainer: Matthew Bauer <mjbauer95@gmail.com>
3 pkgname=pytivo-youtube-hg
6 pkgdesc="Plugin for pyTivo that enables you to download Youtube videos straight from your TiVo.
7 To use add this to your /etc/pyTivo.conf file:
12 url="http://code.google.com/p/pytivoyoutubeplugin"
15 depends=('ffmpeg' 'python' 'pytivo')
16 makedepends=('mercurial')
18 provides=('pytivo-youtube')
27 _hgroot="https://pytivoyoutubeplugin.googlecode.com/hg/"
33 msg "Connecting to googlecode.com HG server...."
35 if [ -d ${srcdir}/$_hgname ] ; then
36 cd $_hgname && hg pull
37 msg "The local files are updated."
42 msg "HG checkout done."
43 msg "Starting install..."
47 mkdir -p ${pkgdir}/usr/share/pyTivo/plugins/youtube
48 cp -r source/plugins/youtube/* ${pkgdir}/usr/share/pyTivo/plugins/youtube