github/workflows/pycopy-test: Upgrade Pycopy to 3.6.1.
[ScratchABlock.git] / tests / const-propagate6.lst.exp.bb
blob979718a413589c84a5823c94dabf49c03e0467b0
1 // Graph props:
2 // name: None
3 // trailing_jumps: True
5 // Predecessors: []
6 // BBlock props:
7 // state_out: {$a0=100}
8 05:
9 $a0 = 100
10 if ($a1 == 100) goto 20
11 Exits: [(COND(EXPR(==[$a1, 100])), '20'), (None, '11')]
13 // Predecessors: ['05']
14 // BBlock props:
15 // state_out: {$a2=1}
16 11:
17 $a2 = 1
18 Exits: [(None, '20')]
20 // Predecessors: ['05', '11']
21 // BBlock props:
22 // state_out: {$a3=3}
23 20:
24 $a3 = 3
25 Exits: []