github/workflows/pycopy-test: Upgrade Pycopy to 3.6.1.
[ScratchABlock.git] / tests / expr-simplify-bitfield.lst.exp.bb
blobf2fc92d11bb49d089697e2313743a1f52b38775d
1 // Graph props:
2 // name: None
3 // trailing_jumps: True
5 // Predecessors: []
6 10:
7 $a2 = (u8)$a2
8 $a2 = (u16)$a2
9 $a2 = (u32)$a2
10 $a2 &= 0x1ff
11 $a2 = bitfield($a2, /*lsb*/1, /*sz*/8)
12 $a2 &= 0xffffff
13 $a3 = $a2 & 0x3
14 return
15 Exits: []