github/workflows/pycopy-test: Upgrade Pycopy to 3.6.1.
[ScratchABlock.git] / tests / if-multi2.lst.exp.bb
blob92d1913b78c9e2c5d75c61481f1ec78c7d32a291
1 // Graph props:
2 // name: None
3 // trailing_jumps: True
5 // Predecessors: []
6 10:
7 if ($a1 == 0) goto 20, ($a1 == 1) goto 30, else goto 40
8 Exits: [(COND(EXPR(==[$a1, 0])), '20'), (COND(EXPR(==[$a1, 1])), '30'), (None, '40')]
10 // Predecessors: []
11 15:
12 nop()
13 Exits: [(None, '20')]
15 // Predecessors: ['10', '15']
16 20:
17 $a2 = 1
18 goto 99
19 Exits: [(None, '99')]
21 // Predecessors: ['10']
22 30:
23 $a2 = 2
24 goto 99
25 Exits: [(None, '99')]
27 // Predecessors: ['10']
28 40:
29 $a2 = 3
30 Exits: [(None, '99')]
32 // Predecessors: ['20', '30', '40']
33 99:
34 return
35 Exits: []