Upstream tarball 20080304
[amule.git] / debian / rules
blob631144ed5390e19dddddd6917815bb2b1aa4284a
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # This file was originally written by Vollstrecker
5 # Uncomment this to turn on verbose mode.
6 export DH_VERBOSE=1
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14 CFLAGS = -Wall -g
16 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17 CFLAGS += -O0
18 else
19 CFLAGS += -O2
20 endif
22 #Here are the packages that can't be compiled separate now
23 general_pkgs = "amule-common"\
24 "amule-skin-gnome"\
25 "amule-skin-kde4"\
26 "amule-skin-tango"\
27 "amule-skin-xfce"\
28 "amule-theme-default"\
29 "amule-theme-php-default"\
30 "amule-theme-chicane"\
31 "amule-xas"
33 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
34 CFLAGS += -O0
35 else
36 CFLAGS += -O2
37 endif
39 # First, get the targets from commandline
40 flags = ${MAKECMDGOALS}
42 #First we have to find out, if we are called from dpkg-buildpackage
44 ifeq ("binary", "$(findstring binary, $(flags))")
46 WXCAS = --enable-wxcas
47 CAS = --enable-cas
48 WEBSERVER = --enable-webserver
49 REMOTEGUI = --enable-amule-gui
50 DAEMON = --enable-amule-daemon
51 ALCC = --enable-alcc
52 ALC = --enable-alc
53 AMULECMD = --enable-amulecmd
54 DEBUGGING = --enable-debug --disable-optimise --disable-profile
55 LANGFLAG = --with-language=all
57 else ifeq ("clean", "$(findstring clean, $(flags))")
59 WXCAS = --enable-wxcas
60 CAS = --enable-cas
61 WEBSERVER = --enable-webserver
62 REMOTEGUI = --enable-amule-gui
63 DAEMON = --enable-amule-daemon
64 ALCC = --enable-alcc
65 ALC = --enable-alc
66 AMULECMD = --enable-amulecmd
67 DEBUGGING = --enable-debug --disable-optimise --disable-profile
68 LANGFLAG = --with-language=all
70 else ifeq ("build", "$(findstring build, $(flags))")
72 WXCAS = --enable-wxcas
73 CAS = --enable-cas
74 WEBSERVER = --enable-webserver
75 REMOTEGUI = --enable-amule-gui
76 DAEMON = --enable-amule-daemon
77 ALCC = --enable-alcc
78 ALC = --enable-alc
79 AMULECMD = --enable-amulecmd
80 DEBUGGING = --enable-debug --disable-optimise --disable-profile
81 LANGFLAG = --with-language=all
83 else
84 #Now we have to check what packages are build to configure only them
86 #We have to filter the right targets (wo_ means without)
87 wo_wxcas = $(subst wxcas, , ${flags})
88 wo_alcc = $(subst alcc, , ${flags})
89 wo_amule_utils_gui = $(subst amule-utils-gui, ,${flags})
90 wo_all_other_amules = $(subst amulecmd, ,$(subst amule-utils-gui, ,$(subst amule-utils, ,${flags})))
91 LANGUAGE := en_GB
93 ifeq ("wxcas", "$(findstring wxcas, $(flags))")
94 WXCAS = --enable-wxcas
95 endif
97 ifeq ("cas", "$(findstring cas, $(wo_wxcas))")
98 CAS = --enable-cas
99 endif
101 ifeq ("webserver", "$(findstring webserver, $(flags))")
102 WEBSERVER = --enable-webserver
103 endif
105 ifeq ("remotegui", "$(findstring remotegui, $(flags))")
106 REMOTEGUI = --enable-amule-gui
107 endif
109 ifeq ("daemon", "$(findstring daemon, $(flags))")
110 DAEMON = --enable-amule-daemon
111 endif
113 ifeq ("alcc", "$(findstring alcc, $(flags))")
114 ALCC = --enable-alcc
115 endif
117 ifeq ("alc", "$(findstring alc, $(wo_alcc))")
118 ALC = --enable-alc
119 endif
121 ifeq ("amulecmd", "$(findstring amulecmd, $(flags))")
122 AMULECMD = --enable-amulecmd
123 endif
125 ifneq ("amule", "$(findstring amule, $(wo_all_other_amules))")
126 AMULE = --disable-monolithic
127 endif
129 ifneq ("ed2k", "$(findstring ed2k, $(flags))")
130 ED2K = --disable-ed2k
131 endif
133 #Now find out if a Metapackage should be build
134 ifeq ("amule-utils-gui", "$(findstring amule-utils-gui, $(flags))")
135 ALC = --enable-alc
136 REMOTEGUI = --enable-amule-gui
137 WXCAS = --enable-wxcas
138 endif
140 ifeq ("amule-utils", "$(findstring amule-utils, $(wo_amule_utils_gui))")
141 ALCC = --enable-alcc
142 AMULECMD = --enable-amulecmd
143 CAS = --enable-cas
144 endif
146 #Find this whole i18n stuff
147 ifneq ("i18n-en-only", "$(findstring i18n-en-only, $(flags))")
149 ifeq ("i18n-ar", "$(findstring i18n-ar, $(flags))")
150 LANGUAGE := $(LANGUAGE),ar
151 endif
153 ifeq ("i18n-bg", "$(findstring i18n-bg, $(flags))")
154 LANGUAGE := $(LANGUAGE),bg
155 endif
157 ifeq ("i18n-ca", "$(findstring i18n-ca, $(flags))")
158 LANGUAGE := $(LANGUAGE),ca
159 endif
161 ifeq ("i18n-da", "$(findstring i18n-da, $(flags))")
162 LANGUAGE := $(LANGUAGE),da
163 endif
165 ifeq ("i18n-de", "$(findstring i18n-de, $(flags))")
166 LANGUAGE := $(LANGUAGE),de
167 endif
169 ifeq ("i18n-es", "$(findstring i18n-es, $(flags))")
170 LANGUAGE := $(LANGUAGE),es
171 endif
173 ifeq ("i18n-et-ee", "$(findstring i18n-et-ee, $(flags))")
174 LANGUAGE := $(LANGUAGE),et_EE
175 endif
177 ifeq ("i18n-eu", "$(findstring i18n-eu, $(flags))")
178 LANGUAGE := $(LANGUAGE),eu
179 endif
181 ifeq ("i18n-fi", "$(findstring i18n-fi, $(flags))")
182 LANGUAGE := $(LANGUAGE),fi
183 endif
185 ifeq ("i18n-fr", "$(findstring i18n-fr, $(flags))")
186 LANGUAGE := $(LANGUAGE),fr
187 endif
189 ifeq ("i18n-gl", "$(findstring i18n-gl, $(flags))")
190 LANGUAGE := $(LANGUAGE),gl
191 endif
193 ifeq ("i18n-hr", "$(findstring i18n-hr, $(flags))")
194 LANGUAGE := $(LANGUAGE),hr
195 endif
197 ifeq ("i18n-hu", "$(findstring i18n-hu, $(flags))")
198 LANGUAGE := $(LANGUAGE),hu
199 endif
201 ifeq ("i18n-it", "$(findstring i18n-it, $(flags))")
202 LANGUAGE := $(LANGUAGE),it
203 endif
205 ifeq ("i18n-it-ch", "$(findstring i18n-it-ch, $(flags))")
206 LANGUAGE := $(LANGUAGE),it_CH
207 endif
209 ifeq ("i18n-ko-kr", "$(findstring i18n-ko-kr, $(flags))")
210 LANGUAGE := $(LANGUAGE),ko_KR
211 endif
213 ifeq ("i18n-lt", "$(findstring i18n-lt, $(flags))")
214 LANGUAGE := $(LANGUAGE),lt
215 endif
217 ifeq ("i18n-nl", "$(findstring i18n-nl, $(flags))")
218 LANGUAGE := $(LANGUAGE),hl
219 endif
221 ifeq ("i18n-nn", "$(findstring i18n-nn, $(flags))")
222 LANGUAGE := $(LANGUAGE),nn
223 endif
225 ifeq ("i18n-pl", "$(findstring i18n-pl, $(flags))")
226 LANGUAGE := $(LANGUAGE),pl
227 endif
229 ifeq ("i18n-pt-br", "$(findstring i18n-pt-br, $(flags))")
230 LANGUAGE := $(LANGUAGE),pt_BR
231 endif
233 ifeq ("i18n-pt-pt", "$(findstring i18n-pt-pt, $(flags))")
234 LANGUAGE := $(LANGUAGE),pt_PT
235 endif
237 ifeq ("i18n-ru", "$(findstring i18n-ru, $(flags))")
238 LANGUAGE := $(LANGUAGE),ru
239 endif
241 ifeq ("i18n-sl", "$(findstring i18n-sl, $(flags))")
242 LANGUAGE := $(LANGUAGE),sl
243 endif
245 ifeq ("i18n-sv", "$(findstring i18n-sv, $(flags))")
246 LANGUAGE := $(LANGUAGE),sv
247 endif
249 ifeq ("i18n-tr", "$(findstring i18n-tr, $(flags))")
250 LANGUAGE := $(LANGUAGE),tr
251 endif
253 ifeq ("i18n-zh-cn", "$(findstring i18n-zh-cn, $(flags))")
254 LANGUAGE := $(LANGUAGE),zh_CN
255 endif
257 ifeq ("i18n-zh-tw", "$(findstring i18n-zh-tw, $(flags))")
258 LANGUAGE := $(LANGUAGE),zh_TW
259 endif
261 ifeq ($(LANGUAGE),en_GB)
262 LANGUAGE = all
263 endif
265 endif
267 LANGFLAG = --with-language=$(LANGUAGE)
269 #And at Last, find out if we compile a debug-package or not.
270 ifeq ("dbg", "$(findstring dbg, $(flags))")
271 DEBUGGING = --enable-debug --disable-optimise --disable-profile
272 else
273 DEBUGGING = --disable-debug --enable-optimize --enable-profile
274 endif
275 endif
277 #Before we start, I want to introduce two sequences for building the packages
278 #I define two, so I can put the commands for the *-dbg packages between them
279 define stage1
280 dh_testdir -p${pkg}
281 dh_testroot -p${pkg}
282 dh_installdirs -p${pkg}
283 dh_installchangelogs docs/Changelog -p${pkg}
284 dh_installdocs -p${pkg}
285 dh_install -Xlicense.txt -p${pkg}
286 dh_installmenu -p${pkg}
287 dh_installdebconf -p${pkg}
288 dh_installman -p${pkg}
289 dh_link -p${pkg}
290 install -D --mode=644 debian/${pkg}.override debian/${pkg}/usr/share/lintian/overrides/${pkg}
291 touch $@
292 endef
294 define stage2
295 dh_compress -X.pl -p${pkg}
296 dh_perl -p${pkg}
297 dh_makeshlibs -p${pkg}
298 dh_installdeb -p${pkg}
299 dh_shlibdeps -p${pkg}
300 dh_gencontrol -p${pkg}
301 dh_md5sums -p${pkg}
302 dh_fixperms -p${pkg}
303 dh_builddeb -p${pkg}
304 touch $@
305 endef
307 #Now we configure this whole thing
308 config.status: configure
309 dh_testdir
310 CFLAGS="$(CFLAGS)" ./configure\
311 --host=$(DEB_HOST_GNU_TYPE)\
312 --build=$(DEB_BUILD_GNU_TYPE)\
313 --prefix=/usr\
314 --mandir=\$${prefix}/share/man\
315 --infodir=\$${prefix}/share/info\
316 --enable-systray\
317 --with-ccache\
318 --enable-utf8-systray\
319 --enable-geoip\
320 --disable-embedded-crypto\
321 ${AMULECMD}\
322 ${DEBUGGING}\
323 ${WEBSERVER}\
324 ${CAS}\
325 ${WXCAS}\
326 ${ALC}\
327 ${ALCC}\
328 ${REMOTEGUI}\
329 ${DAEMON}\
330 ${AMULE}\
331 ${ED2K}\
332 $(LANGFLAG)
335 #And here is the well known clean target
336 clean:
337 dh_testdir
338 dh_testroot
339 rm -f alc
340 rm -f alc-dbg
341 rm -f alcc
342 rm -f alcc-dbg
343 rm -f amule
344 rm -f amule-alc-dbg
345 rm -f amule-alc-stage1
346 rm -f amule-alc-stage2
347 rm -f amule-alcc-dbg
348 rm -f amule-alcc-stage1
349 rm -f amule-alcc-stage2
350 rm -f amule-cas-dbg
351 rm -f amule-cas-stage1
352 rm -f amule-cas-stage2
353 rm -f amule-cmd-dbg
354 rm -f amule-cmd-stage1
355 rm -f amule-cmd-stage2
356 rm -f amule-common
357 rm -f amule-daemon-dbg
358 rm -f amule-daemon-stage1
359 rm -f amule-daemon-stage2
360 rm -f amule-dbg
361 rm -f amule-ed2k-dbg
362 rm -f amule-ed2k-stage1
363 rm -f amule-ed2k-stage2
364 rm -f amule-remote-gui-dbg
365 rm -f amule-remote-gui-stage1
366 rm -f amule-remote-gui-stage2
367 rm -f amule-stage1
368 rm -f amule-stage2
369 rm -f amule-utils
370 rm -f amule-utils-gui
371 rm -f amule-wxcas-dbg
372 rm -f amule-wxcas-stage1
373 rm -f amule-wxcas-stage2
374 rm -f amulecmd
375 rm -f amulecmd-dbg
376 rm -f amuleweb-stage1
377 rm -f amuleweb-stage2
378 rm -f amuleweb-dbg
379 rm -f build-stamp
380 rm -f cas
381 rm -f cas-dbg
382 rm -f compile
383 rm -f daemon
384 rm -f daemon-dbg
385 rm -f ed2k
386 rm -f ed2k-dbg
387 rm -f i18n-ar
388 rm -f i18n-bg
389 rm -f i18n-ca
390 rm -f i18n-da
391 rm -f i18n-de
392 rm -f i18n-en-gb
393 rm -f i18n-es
394 rm -f i18n-et-ee
395 rm -f i18n-eu
396 rm -f i18n-fi
397 rm -f i18n-fr
398 rm -f i18n-gl
399 rm -f i18n-hr
400 rm -f i18n-hu
401 rm -f i18n-it
402 rm -f i18n-it-ch
403 rm -f i18n-ko-kr
404 rm -f i18n-lt
405 rm -f i18n-nl
406 rm -f i18n-nn
407 rm -f i18n-pl
408 rm -f i18n-pt-br
409 rm -f i18n-pt-pt
410 rm -f i18n-ru
411 rm -f i18n-sl
412 rm -f i18n-sv
413 rm -f i18n-tr
414 rm -f i18n-zh-cn
415 rm -f i18n-zh-tw
416 rm -f remotegui
417 rm -f remotegui-dbg
418 rm -f webserver
419 rm -f webserver-dbg
420 rm -f wxcas
421 rm -f wxcas-dbg
423 [ ! -f Makefile ] || $(MAKE) distclean
425 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
426 cp -f /usr/share/misc/config.sub config.sub
427 endif
428 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
429 cp -f /usr/share/misc/config.guess config.guess
430 endif
432 rm -f debian/files
433 dh_clean -k
435 #Some generic targets to check the build process
436 build: build-stamp
438 build-stamp: config.status
439 dh_testdir
441 # Add here commands to compile the package.
442 $(MAKE)
444 touch build-stamp
446 #Now we install the packages all together to the tmp-dir inside of debian/
447 install: build
448 dh_testdir
449 dh_testroot
450 dh_clean -a -k
451 dh_installdirs
453 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
455 #Now first build the packages that are compiled and installed on every build
456 amule-common: install
458 for pkg in $(general_pkgs); do \
459 dh_testdir -p$$pkg; \
460 dh_testroot -p$$pkg; \
461 dh_installdirs -p$$pkg; \
462 dh_installchangelogs docs/Changelog -p$$pkg; \
463 dh_installdocs -p$$pkg; \
464 dh_install -Xlicense.txt -p$$pkg; \
465 dh_installmenu -p$$pkg; \
466 dh_installdebconf -p$$pkg; \
467 dh_installman -p$$pkg; \
468 dh_link -p$$pkg; \
469 install -D --mode=644 debian/$$pkg.override debian/$$pkg/usr/share/lintian/overrides/$$pkg; \
470 dh_compress -X.pl -p$$pkg; \
471 dh_perl -p$$pkg; \
472 dh_makeshlibs -p$$pkg; \
473 dh_installdeb -p$$pkg; \
474 dh_shlibdeps -p$$pkg; \
475 dh_gencontrol -p$$pkg; \
476 dh_md5sums -p$$pkg; \
477 dh_fixperms -p$$pkg; \
478 dh_builddeb -p$$pkg; \
479 done
480 touch amule-common
482 amule-stage1: pkg=amule
483 amule-stage1: amule-common
484 ${stage1}
486 amule-stage2: pkg=amule
487 amule-stage2: amule-stage1
488 ${stage2}
490 amule-ed2k-stage1: pkg=amule-ed2k
491 amule-ed2k-stage1: amule-common
492 ${stage1}
494 amule-ed2k-stage2: pkg=amule-ed2k
495 amule-ed2k-stage2: amule-ed2k-stage1
496 ${stage2}
498 amule-cas-stage1: pkg=amule-cas
499 amule-cas-stage1: amule-common
500 ${stage1}
502 amule-cas-stage2: pkg=amule-cas
503 amule-cas-stage2: amule-cas-stage1
504 ${stage2}
506 amule-wxcas-stage1: pkg=amule-wxcas
507 amule-wxcas-stage1: amule-common
508 ${stage1}
510 amule-wxcas-stage2: pkg=amule-wxcas
511 amule-wxcas-stage2: amule-wxcas-stage1
512 ${stage2}
514 amuleweb-stage1: pkg=amuleweb
515 amuleweb-stage1: amule-common
516 ${stage1}
518 amuleweb-stage2: pkg=amuleweb
519 amuleweb-stage2: amuleweb-stage1
520 ${stage2}
522 amule-remote-gui-stage1: pkg=amule-remote-gui
523 amule-remote-gui-stage1: amule-common
524 ${stage1}
526 amule-remote-gui-stage2: pkg=amule-remote-gui
527 amule-remote-gui-stage2: amule-remote-gui-stage1
528 ${stage2}
530 amule-daemon-stage1: pkg=amule-daemon
531 amule-daemon-stage1: amule-common
532 ${stage1}
534 amule-daemon-stage2: pkg=amule-daemon
535 amule-daemon-stage2: amule-daemon-stage1
536 ${stage2}
538 amule-alc-stage1: pkg=amule-alc
539 amule-alc-stage1: amule-common
540 ${stage1}
542 amule-alc-stage2: pkg=amule-alc
543 amule-alc-stage2: amule-alc-stage1
544 ${stage2}
546 amule-alcc-stage1: pkg=amule-alcc
547 amule-alcc-stage1: amule-common
548 ${stage1}
550 amule-alcc-stage2: pkg=amule-alcc
551 amule-alcc-stage2: amule-alcc-stage1
552 ${stage2}
554 amule-cmd-stage1: pkg=amule-cmd
555 amule-cmd-stage1: amule-common
556 ${stage1}
558 amule-cmd-stage2: pkg=amule-cmd
559 amule-cmd-stage2: amule-alcc-stage1
560 ${stage2}
563 amule-ed2k-dbg: pkg=amule-ed2k-dbg
564 amule-ed2k-dbg: amule-ed2k-stage1
565 ${stage1}
566 dh_strip -pamule-ed2k --dbg-package=amule-ed2k-dbg
567 ${stage2}
569 amule-cas-dbg: pkg=amule-cas-dbg
570 amule-cas-dbg: amule-cas-stage1
571 ${stage1}
572 dh_strip -pamule-cas --dbg-package=amule-cas-dbg
573 ${stage2}
575 amule-wxcas-dbg: pkg=amule-wxcas-dbg
576 amule-wxcas-dbg: amule-wxcas-stage1
577 ${stage1}
578 dh_strip -pamule-wxcas --dbg-package=amule-wxcas-dbg
579 ${stage2}
581 amuleweb-dbg: pkg=amuleweb-dbg
582 amuleweb-dbg: amuleweb-stage1
583 ${stage1}
584 dh_strip -pamuleweb --dbg-package=amuleweb-dbg
585 ${stage2}
587 amule-remote-gui-dbg: pkg=amule-remote-gui-dbg
588 amule-remote-gui-dbg: amule-remote-gui-stage1
589 ${stage1}
590 dh_strip -pamule-remote-gui --dbg-package=amule-remote-gui-dbg
591 ${stage2}
593 amule-daemon-dbg: pkg=amule-daemon-dbg
594 amule-daemon-dbg: amule-daemon-stage1
595 ${stage1}
596 dh_strip -pamule-daemon --dbg-package=amule-daemon-dbg
597 ${stage2}
599 amule-alc-dbg: pkg=amule-alc-dbg
600 amule-alc-dbg: amule-alc-stage1
601 ${stage1}
602 dh_strip -pamule-alc --dbg-package=amule-alc-dbg
603 ${stage2}
605 amule-alcc-dbg: pkg=amule-alcc-dbg
606 amule-alcc-dbg: amule-alcc-stage1
607 ${stage1}
608 dh_strip -pamule-alcc --dbg-package=amule-alcc-dbg
609 ${stage2}
611 amule-cmd-dbg: pkg=amule-cmd-dbg
612 amule-cmd-dbg: amule-cmd-stage1
613 ${stage1}
614 dh_strip -pamule-cmd --dbg-package=amule-cmd-dbg
615 ${stage2}
617 #Now just the targets to map the Commandline Name to the package names
618 amule: amule-stage2
619 touch amule
621 ed2k: amule-ed2k-stage2
622 touch ed2k
624 cas: amule-cas-stage2
625 touch cas
627 wxcas: amule-wxcas-stage2
628 touch wxcas
630 webserver: amuleweb-stage2
631 touch webserver
633 remotegui: amule-remote-gui-stage2
634 touch remotegui
636 daemon: amule-daemon-stage2
637 touch daemon
639 alc: amule-alc-stage2
640 touch alc
642 alcc: amule-alcc-stage2
643 touch alcc
645 amulecmd: amule-cmd-stage2
646 touch amulecmd
648 ed2k-dbg: amule-ed2k-dbg
649 touch ed2k-dbg
651 cas-dbg: amule-cas-dbg
652 touch cas-dbg
654 wxcas-dbg: amule-wxcas-dbg
655 touch wxcas-dbg
657 webserver-dbg: amuleweb-dbg
658 touch webserver-dbg
660 remotegui-dbg: amule-remote-gui-dbg
661 touch remotegui-dbg
663 daemon-dbg: amule-daemon-dbg
664 touch daemon-dbg
666 alc-dbg: amule-alc-dbg
667 touch alc-dbg
669 alcc-dbg: amule-alcc-dbg
670 touch alcc-dbg
672 amulecmd-dbg: amule-cmd-dbg
673 touch amulecmd-dbg
675 amule-dbg: pkg=amule-dbg
676 amule-dbg: amule-stage1
677 ${stage1}
678 dh_strip -pamule --dbg-package=amule-dbg
679 ${stage2}
681 #Her come the Targets for the langauge packages
682 i18n-ar: pkg=amule-i18n-ar
683 i18n-ar: amule-common
684 ${stage1}
685 ${stage2}
687 i18n-bg: pkg=amule-i18n-bg
688 i18n-bg: amule-common
689 ${stage1}
690 ${stage2}
692 i18n-ca: pkg=amule-i18n-ca
693 i18n-ca: amule-common
694 ${stage1}
695 ${stage2}
697 i18n-da: pkg=amule-i18n-da
698 i18n-da: amule-common
699 ${stage1}
700 ${stage2}
702 i18n-de: pkg=amule-i18n-de
703 i18n-de: amule-common
704 ${stage1}
705 ${stage2}
707 i18n-en-gb: pkg=amule-i18n-en-gb
708 i18n-en-gb: amule-common
709 ${stage1}
710 ${stage2}
712 i18n-es: pkg=amule-i18n-es
713 i18n-es: amule-common
714 ${stage1}
715 ${stage2}
717 i18n-et-ee: pkg=amule-i18n-et-ee
718 i18n-et-ee: amule-common
719 ${stage1}
720 ${stage2}
722 i18n-eu: pkg=amule-i18n-eu
723 i18n-eu: amule-common
724 ${stage1}
725 ${stage2}
727 i18n-fi: pkg=amule-i18n-fi
728 i18n-fi: amule-common
729 ${stage1}
730 ${stage2}
732 i18n-fr: pkg=amule-i18n-fr
733 i18n-fr: amule-common
734 ${stage1}
735 ${stage2}
737 i18n-gl: pkg=amule-i18n-gl
738 i18n-gl: amule-common
739 ${stage1}
740 ${stage2}
742 i18n-hr: pkg=amule-i18n-hr
743 i18n-hr: amule-common
744 ${stage1}
745 ${stage2}
747 i18n-hu: pkg=amule-i18n-hu
748 i18n-hu: amule-common
749 ${stage1}
750 ${stage2}
752 i18n-it-ch: pkg=amule-i18n-it-ch
753 i18n-it-ch: amule-common
754 ${stage1}
755 ${stage2}
757 i18n-it: pkg=amule-i18n-it
758 i18n-it: amule-common
759 ${stage1}
760 ${stage2}
762 i18n-ko-kr: pkg=amule-i18n-ko-kr
763 i18n-ko-kr: amule-common
764 ${stage1}
765 ${stage2}
767 i18n-lt: pkg=amule-i18n-lt
768 i18n-lt: amule-common
769 ${stage1}
770 ${stage2}
772 i18n-nn: pkg=amule-i18n-nn
773 i18n-nn: amule-common
774 ${stage1}
775 ${stage2}
777 i18n-nl: pkg=amule-i18n-nl
778 i18n-nl: amule-common
779 ${stage1}
780 ${stage2}
782 i18n-pl: pkg=amule-i18n-pl
783 i18n-pl: amule-common
784 ${stage1}
785 ${stage2}
787 i18n-pt-br: pkg=amule-i18n-pt-br
788 i18n-pt-br: amule-common
789 ${stage1}
790 ${stage2}
792 i18n-pt-pt: pkg=amule-i18n-pt-pt
793 i18n-pt-pt: amule-common
794 ${stage1}
795 ${stage2}
797 i18n-ru: pkg=amule-i18n-ru
798 i18n-ru: amule-common
799 ${stage1}
800 ${stage2}
802 i18n-sl: pkg=amule-i18n-sl
803 i18n-sl: amule-common
804 ${stage1}
805 ${stage2}
807 i18n-sv: pkg=amule-i18n-sv
808 i18n-sv: amule-common
809 ${stage1}
810 ${stage2}
812 i18n-tr: pkg=amule-i18n-tr
813 i18n-tr: amule-common
814 ${stage1}
815 ${stage2}
817 i18n-zh-cn: pkg=amule-i18n-zh-cn
818 i18n-zh-cn: amule-common
819 ${stage1}
820 ${stage2}
822 i18n-zh-tw: pkg=amule-i18n-zh-tw
823 i18n-zh-tw: amule-common
824 ${stage1}
825 ${stage2}
827 #They are just metapackages
828 amule-utils: pkg=amule-utils
829 amule-utils: alcc amulecmd cas
830 ${stage1}
831 ${stage2}
833 amule-utils-gui: pkg=amule-utils-gui
834 amule-utils-gui: alc remotegui wxcas
835 ${stage1}
836 ${stage2}
838 #These Two are empty (Space after Semicolon)
839 debug-packages: amule-dbg ed2k-dbg cas-dbg wxcas-dbg webserver-dbg remotegui-dbg daemon-dbg alc-dbg alcc-dbg amulecmd-dbg ;
840 normal-packages: amule-utils amule-utils-gui amule ed2k webserver daemon ;
842 language-packages: i18n-ar i18n-bg i18n-ca i18n-da i18n-de i18n-en-gb i18n-es i18n-et-ee i18n-eu i18n-fi i18n-fr i18n-gl i18n-hr i18n-hu i18n-it-ch i18n-it i18n-ko-kr i18n-lt i18n-nn i18n-nl i18n-pl i18n-pt-br i18n-pt-pt i18n-ru i18n-sl i18n-sv i18n-tr i18n-zh-cn i18n-zh-tw ;
844 i18n-en-only: ;
846 #Now the targets for dpkg-buildpackage
847 binary-indep: build install
849 binary-arch: debug-packages normal-packages language-packages
851 binary: binary-indep binary-arch
853 help:
854 cat README.Debian-Packages
856 .DEFAULT_GOAL = help
857 .PHONY: build clean binary-indep binary-arch binary install debug-packages normal-packages amule-utils-gui amule-utils i18n-only language-packages