Upstream tarball 20080609
[amule.git] / debian / rules
blob172383bb67f4c3e1fcc2e2300ca734865dcfe3be
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # This file was originally written by Vollstrecker
5 # Uncomment this to turn on verbose mode.
6 export DH_VERBOSE=1
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14 CFLAGS = -Wall -g
16 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17 CFLAGS += -O0
18 else
19 CFLAGS += -O2
20 endif
22 #Here are the packages that can't be compiled separate now
23 general_pkgs = "amule-common"\
24 "amule-skin-gnome"\
25 "amule-skin-kde4"\
26 "amule-skin-tango"\
27 "amule-skin-xfce"\
28 "amule-theme-default"\
29 "amule-theme-php-default"\
30 "amule-theme-chicane"\
31 "amule-xas"
33 # First, get the targets from commandline
34 flags = ${MAKECMDGOALS}
36 #First we have to find out, if we are called from dpkg-buildpackage
38 ifeq ("binary", "$(findstring binary, $(flags))")
40 WXCAS = --enable-wxcas
41 CAS = --enable-cas
42 WEBSERVER = --enable-webserver
43 REMOTEGUI = --enable-amule-gui
44 DAEMON = --enable-amule-daemon
45 ALCC = --enable-alcc
46 ALC = --enable-alc
47 AMULECMD = --enable-amulecmd
48 DEBUGGING = --enable-debug --disable-optimize --disable-profile
49 LANGFLAG = --with-language=all
51 else ifeq ("clean", "$(findstring clean, $(flags))")
53 WXCAS = --enable-wxcas
54 CAS = --enable-cas
55 WEBSERVER = --enable-webserver
56 REMOTEGUI = --enable-amule-gui
57 DAEMON = --enable-amule-daemon
58 ALCC = --enable-alcc
59 ALC = --enable-alc
60 AMULECMD = --enable-amulecmd
61 DEBUGGING = --enable-debug --disable-optimize --disable-profile
62 LANGFLAG = --with-language=all
64 else ifeq ("build", "$(findstring build, $(flags))")
66 WXCAS = --enable-wxcas
67 CAS = --enable-cas
68 WEBSERVER = --enable-webserver
69 REMOTEGUI = --enable-amule-gui
70 DAEMON = --enable-amule-daemon
71 ALCC = --enable-alcc
72 ALC = --enable-alc
73 AMULECMD = --enable-amulecmd
74 DEBUGGING = --enable-debug --disable-optimize --disable-profile
75 LANGFLAG = --with-language=all
77 else
78 #Now we have to check what packages are build to configure only them
80 #We have to filter the right targets (wo_ means without)
81 wo_wxcas = $(subst wxcas, , ${flags})
82 wo_alcc = $(subst alcc, , ${flags})
83 wo_amule_utils_gui = $(subst amule-utils-gui, ,${flags})
84 wo_all_other_amules = $(subst amulecmd, ,$(subst amule-utils-gui, ,$(subst amule-utils, ,${flags})))
85 LANGUAGE := en_GB
87 ifeq ("wxcas", "$(findstring wxcas, $(flags))")
88 WXCAS = --enable-wxcas
89 endif
91 ifeq ("cas", "$(findstring cas, $(wo_wxcas))")
92 CAS = --enable-cas
93 endif
95 ifeq ("webserver", "$(findstring webserver, $(flags))")
96 WEBSERVER = --enable-webserver
97 endif
99 ifeq ("remotegui", "$(findstring remotegui, $(flags))")
100 REMOTEGUI = --enable-amule-gui
101 endif
103 ifeq ("daemon", "$(findstring daemon, $(flags))")
104 DAEMON = --enable-amule-daemon
105 endif
107 ifeq ("alcc", "$(findstring alcc, $(flags))")
108 ALCC = --enable-alcc
109 endif
111 ifeq ("alc", "$(findstring alc, $(wo_alcc))")
112 ALC = --enable-alc
113 endif
115 ifeq ("amulecmd", "$(findstring amulecmd, $(flags))")
116 AMULECMD = --enable-amulecmd
117 endif
119 ifneq ("amule", "$(findstring amule, $(wo_all_other_amules))")
120 AMULE = --disable-monolithic
121 endif
123 ifneq ("ed2k", "$(findstring ed2k, $(flags))")
124 ED2K = --disable-ed2k
125 endif
127 #Now find out if a Metapackage should be build
128 ifeq ("amule-utils-gui", "$(findstring amule-utils-gui, $(flags))")
129 ALC = --enable-alc
130 REMOTEGUI = --enable-amule-gui
131 WXCAS = --enable-wxcas
132 endif
134 ifeq ("amule-utils", "$(findstring amule-utils, $(wo_amule_utils_gui))")
135 ALCC = --enable-alcc
136 AMULECMD = --enable-amulecmd
137 CAS = --enable-cas
138 endif
140 #Find this whole i18n stuff
141 ifneq ("i18n-en-only", "$(findstring i18n-en-only, $(flags))")
143 ifeq ("i18n-ar", "$(findstring i18n-ar, $(flags))")
144 LANGUAGE := $(LANGUAGE),ar
145 endif
147 ifeq ("i18n-bg", "$(findstring i18n-bg, $(flags))")
148 LANGUAGE := $(LANGUAGE),bg
149 endif
151 ifeq ("i18n-ca", "$(findstring i18n-ca, $(flags))")
152 LANGUAGE := $(LANGUAGE),ca
153 endif
155 ifeq ("i18n-da", "$(findstring i18n-da, $(flags))")
156 LANGUAGE := $(LANGUAGE),da
157 endif
159 ifeq ("i18n-de", "$(findstring i18n-de, $(flags))")
160 LANGUAGE := $(LANGUAGE),de
161 endif
163 ifeq ("i18n-es", "$(findstring i18n-es, $(flags))")
164 LANGUAGE := $(LANGUAGE),es
165 endif
167 ifeq ("i18n-et-ee", "$(findstring i18n-et-ee, $(flags))")
168 LANGUAGE := $(LANGUAGE),et_EE
169 endif
171 ifeq ("i18n-eu", "$(findstring i18n-eu, $(flags))")
172 LANGUAGE := $(LANGUAGE),eu
173 endif
175 ifeq ("i18n-fi", "$(findstring i18n-fi, $(flags))")
176 LANGUAGE := $(LANGUAGE),fi
177 endif
179 ifeq ("i18n-fr", "$(findstring i18n-fr, $(flags))")
180 LANGUAGE := $(LANGUAGE),fr
181 endif
183 ifeq ("i18n-gl", "$(findstring i18n-gl, $(flags))")
184 LANGUAGE := $(LANGUAGE),gl
185 endif
187 ifeq ("i18n-hr", "$(findstring i18n-hr, $(flags))")
188 LANGUAGE := $(LANGUAGE),hr
189 endif
191 ifeq ("i18n-hu", "$(findstring i18n-hu, $(flags))")
192 LANGUAGE := $(LANGUAGE),hu
193 endif
195 ifeq ("i18n-it", "$(findstring i18n-it, $(flags))")
196 LANGUAGE := $(LANGUAGE),it
197 endif
199 ifeq ("i18n-it-ch", "$(findstring i18n-it-ch, $(flags))")
200 LANGUAGE := $(LANGUAGE),it_CH
201 endif
203 ifeq ("i18n-ko-kr", "$(findstring i18n-ko-kr, $(flags))")
204 LANGUAGE := $(LANGUAGE),ko_KR
205 endif
207 ifeq ("i18n-lt", "$(findstring i18n-lt, $(flags))")
208 LANGUAGE := $(LANGUAGE),lt
209 endif
211 ifeq ("i18n-nl", "$(findstring i18n-nl, $(flags))")
212 LANGUAGE := $(LANGUAGE),hl
213 endif
215 ifeq ("i18n-nn", "$(findstring i18n-nn, $(flags))")
216 LANGUAGE := $(LANGUAGE),nn
217 endif
219 ifeq ("i18n-pl", "$(findstring i18n-pl, $(flags))")
220 LANGUAGE := $(LANGUAGE),pl
221 endif
223 ifeq ("i18n-pt-br", "$(findstring i18n-pt-br, $(flags))")
224 LANGUAGE := $(LANGUAGE),pt_BR
225 endif
227 ifeq ("i18n-pt-pt", "$(findstring i18n-pt-pt, $(flags))")
228 LANGUAGE := $(LANGUAGE),pt_PT
229 endif
231 ifeq ("i18n-ru", "$(findstring i18n-ru, $(flags))")
232 LANGUAGE := $(LANGUAGE),ru
233 endif
235 ifeq ("i18n-sl", "$(findstring i18n-sl, $(flags))")
236 LANGUAGE := $(LANGUAGE),sl
237 endif
239 ifeq ("i18n-sv", "$(findstring i18n-sv, $(flags))")
240 LANGUAGE := $(LANGUAGE),sv
241 endif
243 ifeq ("i18n-tr", "$(findstring i18n-tr, $(flags))")
244 LANGUAGE := $(LANGUAGE),tr
245 endif
247 ifeq ("i18n-zh-cn", "$(findstring i18n-zh-cn, $(flags))")
248 LANGUAGE := $(LANGUAGE),zh_CN
249 endif
251 ifeq ("i18n-zh-tw", "$(findstring i18n-zh-tw, $(flags))")
252 LANGUAGE := $(LANGUAGE),zh_TW
253 endif
255 ifeq ($(LANGUAGE),en_GB)
256 LANGUAGE = all
257 endif
259 endif
261 LANGFLAG = --with-language=$(LANGUAGE)
263 #And at Last, find out if we compile a debug-package or not.
264 ifeq ("dbg", "$(findstring dbg, $(flags))")
265 DEBUGGING = --enable-debug --disable-optimize --disable-profile
266 else
267 DEBUGGING = --disable-debug --enable-optimize --disable-profile
268 endif
269 endif
271 #Before we start, I want to introduce two sequences for building the packages
272 #I define two, so I can put the commands for the *-dbg packages between them
273 define stage1
274 dh_testdir -p${pkg}
275 dh_testroot -p${pkg}
276 dh_installdirs -p${pkg}
277 dh_installchangelogs docs/Changelog -p${pkg}
278 dh_installdocs -p${pkg}
279 dh_install -Xlicense.txt -p${pkg}
280 dh_installmenu -p${pkg}
281 dh_installdebconf -p${pkg}
282 dh_installman -p${pkg}
283 dh_link -p${pkg}
284 install -D --mode=644 debian/${pkg}.override debian/${pkg}/usr/share/lintian/overrides/${pkg}
285 touch $@
286 endef
288 define stage2
289 dh_compress -X.pl -p${pkg}
290 dh_perl -p${pkg}
291 dh_makeshlibs -p${pkg}
292 dh_installdeb -p${pkg}
293 dh_shlibdeps -p${pkg}
294 dh_gencontrol -p${pkg}
295 dh_md5sums -p${pkg}
296 dh_fixperms -p${pkg}
297 dh_builddeb -p${pkg}
298 touch $@
299 endef
301 #Now we configure this whole thing
302 config.status: configure
303 dh_testdir
304 CFLAGS="$(CFLAGS)" ./configure\
305 --host=$(DEB_HOST_GNU_TYPE)\
306 --build=$(DEB_BUILD_GNU_TYPE)\
307 --prefix=/usr\
308 --mandir=\$${prefix}/share/man\
309 --infodir=\$${prefix}/share/info\
310 --enable-systray\
311 --with-ccache\
312 --enable-utf8-systray\
313 --enable-geoip\
314 --disable-embedded-crypto\
315 ${AMULECMD}\
316 ${DEBUGGING}\
317 ${WEBSERVER}\
318 ${CAS}\
319 ${WXCAS}\
320 ${ALC}\
321 ${ALCC}\
322 ${REMOTEGUI}\
323 ${DAEMON}\
324 ${AMULE}\
325 ${ED2K}\
326 $(LANGFLAG)
329 #And here is the well known clean target
330 clean:
331 dh_testdir
332 dh_testroot
333 rm -f alc
334 rm -f alc-dbg
335 rm -f alcc
336 rm -f alcc-dbg
337 rm -f amule
338 rm -f amule-alc-dbg
339 rm -f amule-alc-stage1
340 rm -f amule-alc-stage2
341 rm -f amule-alcc-dbg
342 rm -f amule-alcc-stage1
343 rm -f amule-alcc-stage2
344 rm -f amule-cas-dbg
345 rm -f amule-cas-stage1
346 rm -f amule-cas-stage2
347 rm -f amule-cmd-dbg
348 rm -f amule-cmd-stage1
349 rm -f amule-cmd-stage2
350 rm -f amule-common
351 rm -f amule-daemon-dbg
352 rm -f amule-daemon-stage1
353 rm -f amule-daemon-stage2
354 rm -f amule-dbg
355 rm -f amule-ed2k-dbg
356 rm -f amule-ed2k-stage1
357 rm -f amule-ed2k-stage2
358 rm -f amule-remote-gui-dbg
359 rm -f amule-remote-gui-stage1
360 rm -f amule-remote-gui-stage2
361 rm -f amule-stage1
362 rm -f amule-stage2
363 rm -f amule-utils
364 rm -f amule-utils-gui
365 rm -f amule-wxcas-dbg
366 rm -f amule-wxcas-stage1
367 rm -f amule-wxcas-stage2
368 rm -f amulecmd
369 rm -f amulecmd-dbg
370 rm -f amuleweb-stage1
371 rm -f amuleweb-stage2
372 rm -f amuleweb-dbg
373 rm -f build-stamp
374 rm -f cas
375 rm -f cas-dbg
376 rm -f compile
377 rm -f daemon
378 rm -f daemon-dbg
379 rm -f ed2k
380 rm -f ed2k-dbg
381 rm -f i18n-ar
382 rm -f i18n-bg
383 rm -f i18n-ca
384 rm -f i18n-da
385 rm -f i18n-de
386 rm -f i18n-en-gb
387 rm -f i18n-es
388 rm -f i18n-et-ee
389 rm -f i18n-eu
390 rm -f i18n-fi
391 rm -f i18n-fr
392 rm -f i18n-gl
393 rm -f i18n-hr
394 rm -f i18n-hu
395 rm -f i18n-it
396 rm -f i18n-it-ch
397 rm -f i18n-ko-kr
398 rm -f i18n-lt
399 rm -f i18n-nl
400 rm -f i18n-nn
401 rm -f i18n-pl
402 rm -f i18n-pt-br
403 rm -f i18n-pt-pt
404 rm -f i18n-ru
405 rm -f i18n-sl
406 rm -f i18n-sv
407 rm -f i18n-tr
408 rm -f i18n-zh-cn
409 rm -f i18n-zh-tw
410 rm -f remotegui
411 rm -f remotegui-dbg
412 rm -f webserver
413 rm -f webserver-dbg
414 rm -f wxcas
415 rm -f wxcas-dbg
417 [ ! -f Makefile ] || $(MAKE) distclean
419 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
420 cp -f /usr/share/misc/config.sub config.sub
421 endif
422 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
423 cp -f /usr/share/misc/config.guess config.guess
424 endif
426 rm -f debian/files
427 dh_clean -k
429 #Some generic targets to check the build process
430 build: build-stamp
432 build-stamp: config.status
433 dh_testdir
435 # Add here commands to compile the package.
436 $(MAKE)
438 touch build-stamp
440 #Now we install the packages all together to the tmp-dir inside of debian/
441 install: build
442 dh_testdir
443 dh_testroot
444 dh_clean -a -k
445 dh_installdirs
447 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
449 #Now first build the packages that are compiled and installed on every build
450 amule-common: install
452 for pkg in $(general_pkgs); do \
453 dh_testdir -p$$pkg; \
454 dh_testroot -p$$pkg; \
455 dh_installdirs -p$$pkg; \
456 dh_installchangelogs docs/Changelog -p$$pkg; \
457 dh_installdocs -p$$pkg; \
458 dh_install -Xlicense.txt -p$$pkg; \
459 dh_installmenu -p$$pkg; \
460 dh_installdebconf -p$$pkg; \
461 dh_installman -p$$pkg; \
462 dh_link -p$$pkg; \
463 install -D --mode=644 debian/$$pkg.override debian/$$pkg/usr/share/lintian/overrides/$$pkg; \
464 dh_compress -X.pl -p$$pkg; \
465 dh_perl -p$$pkg; \
466 dh_makeshlibs -p$$pkg; \
467 dh_installdeb -p$$pkg; \
468 dh_shlibdeps -p$$pkg; \
469 dh_gencontrol -p$$pkg; \
470 dh_md5sums -p$$pkg; \
471 dh_fixperms -p$$pkg; \
472 dh_builddeb -p$$pkg; \
473 done
474 touch amule-common
476 amule-stage1: pkg=amule
477 amule-stage1: amule-common
478 ${stage1}
480 amule-stage2: pkg=amule
481 amule-stage2: amule-stage1
482 ${stage2}
484 amule-ed2k-stage1: pkg=amule-ed2k
485 amule-ed2k-stage1: amule-common
486 ${stage1}
488 amule-ed2k-stage2: pkg=amule-ed2k
489 amule-ed2k-stage2: amule-ed2k-stage1
490 ${stage2}
492 amule-cas-stage1: pkg=amule-cas
493 amule-cas-stage1: amule-common
494 ${stage1}
496 amule-cas-stage2: pkg=amule-cas
497 amule-cas-stage2: amule-cas-stage1
498 ${stage2}
500 amule-wxcas-stage1: pkg=amule-wxcas
501 amule-wxcas-stage1: amule-common
502 ${stage1}
504 amule-wxcas-stage2: pkg=amule-wxcas
505 amule-wxcas-stage2: amule-wxcas-stage1
506 ${stage2}
508 amuleweb-stage1: pkg=amuleweb
509 amuleweb-stage1: amule-common
510 ${stage1}
512 amuleweb-stage2: pkg=amuleweb
513 amuleweb-stage2: amuleweb-stage1
514 ${stage2}
516 amule-remote-gui-stage1: pkg=amule-remote-gui
517 amule-remote-gui-stage1: amule-common
518 ${stage1}
520 amule-remote-gui-stage2: pkg=amule-remote-gui
521 amule-remote-gui-stage2: amule-remote-gui-stage1
522 ${stage2}
524 amule-daemon-stage1: pkg=amule-daemon
525 amule-daemon-stage1: amule-common
526 ${stage1}
528 amule-daemon-stage2: pkg=amule-daemon
529 amule-daemon-stage2: amule-daemon-stage1
530 ${stage2}
532 amule-alc-stage1: pkg=amule-alc
533 amule-alc-stage1: amule-common
534 ${stage1}
536 amule-alc-stage2: pkg=amule-alc
537 amule-alc-stage2: amule-alc-stage1
538 ${stage2}
540 amule-alcc-stage1: pkg=amule-alcc
541 amule-alcc-stage1: amule-common
542 ${stage1}
544 amule-alcc-stage2: pkg=amule-alcc
545 amule-alcc-stage2: amule-alcc-stage1
546 ${stage2}
548 amule-cmd-stage1: pkg=amule-cmd
549 amule-cmd-stage1: amule-common
550 ${stage1}
552 amule-cmd-stage2: pkg=amule-cmd
553 amule-cmd-stage2: amule-alcc-stage1
554 ${stage2}
557 amule-ed2k-dbg: pkg=amule-ed2k-dbg
558 amule-ed2k-dbg: amule-ed2k-stage1
559 ${stage1}
560 dh_strip -pamule-ed2k --dbg-package=amule-ed2k-dbg
561 ${stage2}
563 amule-cas-dbg: pkg=amule-cas-dbg
564 amule-cas-dbg: amule-cas-stage1
565 ${stage1}
566 dh_strip -pamule-cas --dbg-package=amule-cas-dbg
567 ${stage2}
569 amule-wxcas-dbg: pkg=amule-wxcas-dbg
570 amule-wxcas-dbg: amule-wxcas-stage1
571 ${stage1}
572 dh_strip -pamule-wxcas --dbg-package=amule-wxcas-dbg
573 ${stage2}
575 amuleweb-dbg: pkg=amuleweb-dbg
576 amuleweb-dbg: amuleweb-stage1
577 ${stage1}
578 dh_strip -pamuleweb --dbg-package=amuleweb-dbg
579 ${stage2}
581 amule-remote-gui-dbg: pkg=amule-remote-gui-dbg
582 amule-remote-gui-dbg: amule-remote-gui-stage1
583 ${stage1}
584 dh_strip -pamule-remote-gui --dbg-package=amule-remote-gui-dbg
585 ${stage2}
587 amule-daemon-dbg: pkg=amule-daemon-dbg
588 amule-daemon-dbg: amule-daemon-stage1
589 ${stage1}
590 dh_strip -pamule-daemon --dbg-package=amule-daemon-dbg
591 ${stage2}
593 amule-alc-dbg: pkg=amule-alc-dbg
594 amule-alc-dbg: amule-alc-stage1
595 ${stage1}
596 dh_strip -pamule-alc --dbg-package=amule-alc-dbg
597 ${stage2}
599 amule-alcc-dbg: pkg=amule-alcc-dbg
600 amule-alcc-dbg: amule-alcc-stage1
601 ${stage1}
602 dh_strip -pamule-alcc --dbg-package=amule-alcc-dbg
603 ${stage2}
605 amule-cmd-dbg: pkg=amule-cmd-dbg
606 amule-cmd-dbg: amule-cmd-stage1
607 ${stage1}
608 dh_strip -pamule-cmd --dbg-package=amule-cmd-dbg
609 ${stage2}
611 #Now just the targets to map the Commandline Name to the package names
612 amule: amule-stage2
613 touch amule
615 ed2k: amule-ed2k-stage2
616 touch ed2k
618 cas: amule-cas-stage2
619 touch cas
621 wxcas: amule-wxcas-stage2
622 touch wxcas
624 webserver: amuleweb-stage2
625 touch webserver
627 remotegui: amule-remote-gui-stage2
628 touch remotegui
630 daemon: amule-daemon-stage2
631 touch daemon
633 alc: amule-alc-stage2
634 touch alc
636 alcc: amule-alcc-stage2
637 touch alcc
639 amulecmd: amule-cmd-stage2
640 touch amulecmd
642 ed2k-dbg: amule-ed2k-dbg
643 touch ed2k-dbg
645 cas-dbg: amule-cas-dbg
646 touch cas-dbg
648 wxcas-dbg: amule-wxcas-dbg
649 touch wxcas-dbg
651 webserver-dbg: amuleweb-dbg
652 touch webserver-dbg
654 remotegui-dbg: amule-remote-gui-dbg
655 touch remotegui-dbg
657 daemon-dbg: amule-daemon-dbg
658 touch daemon-dbg
660 alc-dbg: amule-alc-dbg
661 touch alc-dbg
663 alcc-dbg: amule-alcc-dbg
664 touch alcc-dbg
666 amulecmd-dbg: amule-cmd-dbg
667 touch amulecmd-dbg
669 amule-dbg: pkg=amule-dbg
670 amule-dbg: amule-stage1
671 ${stage1}
672 dh_strip -pamule --dbg-package=amule-dbg
673 ${stage2}
675 #Her come the Targets for the langauge packages
676 i18n-ar: pkg=amule-i18n-ar
677 i18n-ar: amule-common
678 ${stage1}
679 ${stage2}
681 i18n-bg: pkg=amule-i18n-bg
682 i18n-bg: amule-common
683 ${stage1}
684 ${stage2}
686 i18n-ca: pkg=amule-i18n-ca
687 i18n-ca: amule-common
688 ${stage1}
689 ${stage2}
691 i18n-da: pkg=amule-i18n-da
692 i18n-da: amule-common
693 ${stage1}
694 ${stage2}
696 i18n-de: pkg=amule-i18n-de
697 i18n-de: amule-common
698 ${stage1}
699 ${stage2}
701 i18n-en-gb: pkg=amule-i18n-en-gb
702 i18n-en-gb: amule-common
703 ${stage1}
704 ${stage2}
706 i18n-es: pkg=amule-i18n-es
707 i18n-es: amule-common
708 ${stage1}
709 ${stage2}
711 i18n-et-ee: pkg=amule-i18n-et-ee
712 i18n-et-ee: amule-common
713 ${stage1}
714 ${stage2}
716 i18n-eu: pkg=amule-i18n-eu
717 i18n-eu: amule-common
718 ${stage1}
719 ${stage2}
721 i18n-fi: pkg=amule-i18n-fi
722 i18n-fi: amule-common
723 ${stage1}
724 ${stage2}
726 i18n-fr: pkg=amule-i18n-fr
727 i18n-fr: amule-common
728 ${stage1}
729 ${stage2}
731 i18n-gl: pkg=amule-i18n-gl
732 i18n-gl: amule-common
733 ${stage1}
734 ${stage2}
736 i18n-hr: pkg=amule-i18n-hr
737 i18n-hr: amule-common
738 ${stage1}
739 ${stage2}
741 i18n-hu: pkg=amule-i18n-hu
742 i18n-hu: amule-common
743 ${stage1}
744 ${stage2}
746 i18n-it-ch: pkg=amule-i18n-it-ch
747 i18n-it-ch: amule-common
748 ${stage1}
749 ${stage2}
751 i18n-it: pkg=amule-i18n-it
752 i18n-it: amule-common
753 ${stage1}
754 ${stage2}
756 i18n-ko-kr: pkg=amule-i18n-ko-kr
757 i18n-ko-kr: amule-common
758 ${stage1}
759 ${stage2}
761 i18n-lt: pkg=amule-i18n-lt
762 i18n-lt: amule-common
763 ${stage1}
764 ${stage2}
766 i18n-nn: pkg=amule-i18n-nn
767 i18n-nn: amule-common
768 ${stage1}
769 ${stage2}
771 i18n-nl: pkg=amule-i18n-nl
772 i18n-nl: amule-common
773 ${stage1}
774 ${stage2}
776 i18n-pl: pkg=amule-i18n-pl
777 i18n-pl: amule-common
778 ${stage1}
779 ${stage2}
781 i18n-pt-br: pkg=amule-i18n-pt-br
782 i18n-pt-br: amule-common
783 ${stage1}
784 ${stage2}
786 i18n-pt-pt: pkg=amule-i18n-pt-pt
787 i18n-pt-pt: amule-common
788 ${stage1}
789 ${stage2}
791 i18n-ru: pkg=amule-i18n-ru
792 i18n-ru: amule-common
793 ${stage1}
794 ${stage2}
796 i18n-sl: pkg=amule-i18n-sl
797 i18n-sl: amule-common
798 ${stage1}
799 ${stage2}
801 i18n-sv: pkg=amule-i18n-sv
802 i18n-sv: amule-common
803 ${stage1}
804 ${stage2}
806 i18n-tr: pkg=amule-i18n-tr
807 i18n-tr: amule-common
808 ${stage1}
809 ${stage2}
811 i18n-zh-cn: pkg=amule-i18n-zh-cn
812 i18n-zh-cn: amule-common
813 ${stage1}
814 ${stage2}
816 i18n-zh-tw: pkg=amule-i18n-zh-tw
817 i18n-zh-tw: amule-common
818 ${stage1}
819 ${stage2}
821 #They are just metapackages
822 amule-utils: pkg=amule-utils
823 amule-utils: alcc amulecmd cas
824 ${stage1}
825 ${stage2}
827 amule-utils-gui: pkg=amule-utils-gui
828 amule-utils-gui: alc remotegui wxcas
829 ${stage1}
830 ${stage2}
832 #These Two are empty (Space after Semicolon)
833 debug-packages: amule-dbg ed2k-dbg cas-dbg wxcas-dbg webserver-dbg remotegui-dbg daemon-dbg alc-dbg alcc-dbg amulecmd-dbg ;
834 normal-packages: amule-utils amule-utils-gui amule ed2k webserver daemon ;
836 language-packages: i18n-ar i18n-bg i18n-ca i18n-da i18n-de i18n-en-gb i18n-es i18n-et-ee i18n-eu i18n-fi i18n-fr i18n-gl i18n-hr i18n-hu i18n-it-ch i18n-it i18n-ko-kr i18n-lt i18n-nn i18n-nl i18n-pl i18n-pt-br i18n-pt-pt i18n-ru i18n-sl i18n-sv i18n-tr i18n-zh-cn i18n-zh-tw ;
838 i18n-en-only: ;
840 #Now the targets for dpkg-buildpackage
841 binary-indep: build install
843 binary-arch: debug-packages normal-packages language-packages
845 binary: binary-indep binary-arch
847 help:
848 cat README.Debian-Packages
850 .DEFAULT_GOAL = help
851 .PHONY: build clean binary-indep binary-arch binary install debug-packages normal-packages amule-utils-gui amule-utils i18n-only language-packages