3 # This file was originally written by Vollstrecker
5 # Uncomment this to turn on verbose mode.
7 export DEB_BUILD_OPTIONS_PARALLEL
=3
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
13 #Here are the packages that can't be compiled separate now
14 general_pkgs
= "amule-common"\
17 "amule-skin-mac-gray"\
18 "amule-skin-priscilla"\
22 # First, get the targets from commandline
23 flags
= ${MAKECMDGOALS}
25 #First we have to find out, if we are called from dpkg-buildpackage
27 ifeq ("binary", "$(findstring binary, $(flags))")
29 WXCAS
= --enable-wxcas
32 WEBSERVER
= --enable-webserver
33 REMOTEGUI
= --enable-amule-gui
34 DAEMON
= --enable-amule-daemon
37 AMULECMD
= --enable-amulecmd
38 DEBUGGING
= --enable-debug
--disable-optimize
--disable-profile
39 LANGFLAG
= --with-language
=all
41 else ifeq ("build", "$(findstring build, $(flags))")
43 WXCAS
= --enable-wxcas
46 WEBSERVER
= --enable-webserver
47 REMOTEGUI
= --enable-amule-gui
48 DAEMON
= --enable-amule-daemon
51 AMULECMD
= --enable-amulecmd
52 DEBUGGING
= --enable-debug
--disable-optimize
--disable-profile
53 LANGFLAG
= --with-language
=all
56 #Now we have to check what packages are build to configure only them
58 #We have to filter the right targets (wo_ means without)
59 wo_wxcas
= $(subst wxcas
,, ${flags})
60 wo_alcc
= $(subst alcc
,, ${flags})
61 wo_amule_utils_gui
= $(subst amule-utils-gui
,,${flags})
62 wo_all_other_amules
= $(subst amulecmd
,,$(subst amule-utils-gui
,,$(subst amule-utils
,,${flags})))
65 ifeq ("wxcas", "$(findstring wxcas, $(flags))")
66 WXCAS
= --enable-wxcas
69 ifeq ("cas", "$(findstring cas, $(wo_wxcas))")
73 ifeq ("webserver", "$(findstring webserver, $(flags))")
74 WEBSERVER
= --enable-webserver
77 ifeq ("remotegui", "$(findstring remotegui, $(flags))")
78 REMOTEGUI
= --enable-amule-gui
81 ifeq ("daemon", "$(findstring daemon, $(flags))")
82 DAEMON
= --enable-amule-daemon
85 ifeq ("alcc", "$(findstring alcc, $(flags))")
89 ifeq ("alc", "$(findstring alc, $(wo_alcc))")
93 ifeq ("amulecmd", "$(findstring amulecmd, $(flags))")
94 AMULECMD
= --enable-amulecmd
97 ifneq ("amule", "$(findstring amule, $(wo_all_other_amules))")
98 AMULE
= --disable-monolithic
101 ifneq ("ed2k", "$(findstring ed2k, $(flags))")
102 ED2K
= --disable-ed2k
105 ifeq ("xas", "$(findstring xas, $(flags))")
109 #Now find out if a Metapackage should be build
110 ifeq ("amule-utils-gui", "$(findstring amule-utils-gui, $(flags))")
112 REMOTEGUI
= --enable-amule-gui
113 WXCAS
= --enable-wxcas
116 ifeq ("amule-utils", "$(findstring amule-utils, $(wo_amule_utils_gui))")
118 AMULECMD
= --enable-amulecmd
122 #Find this whole i18n stuff
123 ifneq ("i18n-en-only", "$(findstring i18n-en-only, $(flags))")
125 ifeq ("i18n-ar", "$(findstring i18n-ar, $(flags))")
126 LANGUAGE
:= $(LANGUAGE
),ar
129 ifeq ("i18n-ast", "$(findstring i18n-ast, $(flags))")
130 LANGUAGE
:= $(LANGUAGE
),ast
133 ifeq ("i18n-bg", "$(findstring i18n-bg, $(flags))")
134 LANGUAGE
:= $(LANGUAGE
),bg
137 ifeq ("i18n-ca", "$(findstring i18n-ca, $(flags))")
138 LANGUAGE
:= $(LANGUAGE
),ca
141 ifeq ("i18n-cs", "$(findstring i18n-cs, $(flags))")
142 LANGUAGE
:= $(LANGUAGE
),cs
145 ifeq ("i18n-da", "$(findstring i18n-da, $(flags))")
146 LANGUAGE
:= $(LANGUAGE
),da
149 ifeq ("i18n-de", "$(findstring i18n-de, $(flags))")
150 LANGUAGE
:= $(LANGUAGE
),de
153 ifeq ("i18n-el", "$(findstring i18n-el, $(flags))")
154 LANGUAGE
:= $(LANGUAGE
),el
157 ifeq ("i18n-es", "$(findstring i18n-es, $(flags))")
158 LANGUAGE
:= $(LANGUAGE
),es
161 ifeq ("i18n-et-ee", "$(findstring i18n-et-ee, $(flags))")
162 LANGUAGE
:= $(LANGUAGE
),et_EE
165 ifeq ("i18n-eu", "$(findstring i18n-eu, $(flags))")
166 LANGUAGE
:= $(LANGUAGE
),eu
169 ifeq ("i18n-fi", "$(findstring i18n-fi, $(flags))")
170 LANGUAGE
:= $(LANGUAGE
),fi
173 ifeq ("i18n-fr", "$(findstring i18n-fr, $(flags))")
174 LANGUAGE
:= $(LANGUAGE
),fr
177 ifeq ("i18n-gl", "$(findstring i18n-gl, $(flags))")
178 LANGUAGE
:= $(LANGUAGE
),gl
181 ifeq ("i18n-he", "$(findstring i18n-he, $(flags))")
182 LANGUAGE
:= $(LANGUAGE
),he
185 ifeq ("i18n-hr", "$(findstring i18n-hr, $(flags))")
186 LANGUAGE
:= $(LANGUAGE
),hr
189 ifeq ("i18n-hu", "$(findstring i18n-hu, $(flags))")
190 LANGUAGE
:= $(LANGUAGE
),hu
193 ifeq ("i18n-it", "$(findstring i18n-it, $(flags))")
194 LANGUAGE
:= $(LANGUAGE
),it
197 ifeq ("i18n-it-ch", "$(findstring i18n-it-ch, $(flags))")
198 LANGUAGE
:= $(LANGUAGE
),it_CH
201 ifeq ("i18n-ja", "$(findstring i18n-ja, $(flags))")
202 LANGUAGE
:= $(LANGUAGE
),ja
205 ifeq ("i18n-ko-kr", "$(findstring i18n-ko-kr, $(flags))")
206 LANGUAGE
:= $(LANGUAGE
),ko_KR
209 ifeq ("i18n-lt", "$(findstring i18n-lt, $(flags))")
210 LANGUAGE
:= $(LANGUAGE
),lt
213 ifeq ("i18n-nl", "$(findstring i18n-nl, $(flags))")
214 LANGUAGE
:= $(LANGUAGE
),hl
217 ifeq ("i18n-nn", "$(findstring i18n-nn, $(flags))")
218 LANGUAGE
:= $(LANGUAGE
),nn
221 ifeq ("i18n-pl", "$(findstring i18n-pl, $(flags))")
222 LANGUAGE
:= $(LANGUAGE
),pl
225 ifeq ("i18n-pt-br", "$(findstring i18n-pt-br, $(flags))")
226 LANGUAGE
:= $(LANGUAGE
),pt_BR
229 ifeq ("i18n-pt-pt", "$(findstring i18n-pt-pt, $(flags))")
230 LANGUAGE
:= $(LANGUAGE
),pt_PT
233 ifeq ("i18n-ru", "$(findstring i18n-ru, $(flags))")
234 LANGUAGE
:= $(LANGUAGE
),ru
237 ifeq ("i18n-sl", "$(findstring i18n-sl, $(flags))")
238 LANGUAGE
:= $(LANGUAGE
),sl
241 ifeq ("i18n-sq", "$(findstring i18n-sq, $(flags))")
242 LANGUAGE
:= $(LANGUAGE
),sq
245 ifeq ("i18n-sv", "$(findstring i18n-sv, $(flags))")
246 LANGUAGE
:= $(LANGUAGE
),sv
249 ifeq ("i18n-tr", "$(findstring i18n-tr, $(flags))")
250 LANGUAGE
:= $(LANGUAGE
),tr
253 ifeq ("i18n-uk", "$(findstring i18n-uk, $(flags))")
254 LANGUAGE
:= $(LANGUAGE
),uk
257 ifeq ("i18n-zh-cn", "$(findstring i18n-zh-cn, $(flags))")
258 LANGUAGE
:= $(LANGUAGE
),zh_CN
261 ifeq ("i18n-zh-tw", "$(findstring i18n-zh-tw, $(flags))")
262 LANGUAGE
:= $(LANGUAGE
),zh_TW
265 ifeq ($(LANGUAGE
),en_GB
)
271 LANGFLAG
= --with-language
=$(LANGUAGE
)
273 #And at Last, find out if we compile a debug-package or not.
274 ifeq ("dbg", "$(findstring dbg, $(flags))")
275 DEBUGGING
= --enable-debug
--disable-optimize
--disable-profile
277 DEBUGGING
= --disable-debug
--enable-optimize
--disable-profile
281 #Before we start, I want to introduce two sequences for building the packages
282 #I define two, so I can put the commands for the *-dbg packages between them
284 dh_testdir
-p
$(subst -stage1
,,$@
)
285 dh_testroot
-p
$(subst -stage1
,,$@
)
286 dh_installdirs
-p
$(subst -stage1
,,$@
)
287 dh_installchangelogs docs
/Changelog
-p
$(subst -stage1
,,$@
)
288 dh_installdocs
-p
$(subst -stage1
,,$@
)
289 dh_install
-Xlicense.txt
-p
$(subst -stage1
,,$@
)
290 dh_installmenu
-p
$(subst -stage1
,,$@
)
291 dh_installdebconf
-p
$(subst -stage1
,,$@
)
292 dh_installman
-p
$(subst -stage1
,,$@
)
293 dh_link
-p
$(subst -stage1
,,$@
)
294 dh_lintian
-p
$(subst -stage1
,,$@
)
299 dh_strip
-p
$(subst -dbg
,,$@
) --dbg-package
=$@
303 dh_compress
-X.pl
-p
$(subst -stage2
,,$@
)
304 dh_perl
-p
$(subst -stage2
,,$@
)
305 dh_makeshlibs
-p
$(subst -stage2
,,$@
)
306 dh_installdeb
-p
$(subst -stage2
,,$@
)
307 dh_shlibdeps
-p
$(subst -stage2
,,$@
)
308 dh_gencontrol
-p
$(subst -stage2
,,$@
)
309 dh_md5sums
-p
$(subst -stage2
,,$@
)
310 dh_fixperms
-p
$(subst -stage2
,,$@
)
311 dh_builddeb
-p
$(subst -stage2
,,$@
)
315 #Now we configure this whole thing
316 config.status
: configure
318 CFLAGS
="$(CFLAGS)" dh_auto_configure
-- --host
=$(DEB_HOST_GNU_TYPE
)\
335 #And here is the well known clean target
343 #Some generic targets to check the build process
346 build-stamp
: config.status
353 #Now we install the packages all together to the tmp-dir inside of debian/
360 #Now first build the packages that are compiled and installed on every build
361 amule-common
: install
363 for pkg in
$(general_pkgs
); do \
364 dh_testdir
-p
$$pkg; \
365 dh_testroot
-p
$$pkg; \
366 dh_installdirs
-p
$$pkg; \
367 dh_installchangelogs docs
/Changelog
-p
$$pkg; \
368 dh_installdocs
-p
$$pkg; \
369 dh_install
-Xlicense.txt
-p
$$pkg; \
370 dh_installmenu
-p
$$pkg; \
371 dh_installdebconf
-p
$$pkg; \
372 dh_installman
-p
$$pkg; \
374 dh_lintian
-p
$$pkg; \
375 dh_compress
-X.pl
-p
$$pkg; \
377 dh_makeshlibs
-p
$$pkg; \
378 dh_installdeb
-p
$$pkg; \
379 dh_shlibdeps
-p
$$pkg; \
380 dh_gencontrol
-p
$$pkg; \
381 dh_md5sums
-p
$$pkg; \
382 dh_fixperms
-p
$$pkg; \
383 dh_builddeb
-p
$$pkg; \
387 %-stage1
: amule-common
393 amule-
%-dbg
: amule-
%-stage1
398 amule-dbg
: amule-stage1
403 amuleweb-dbg
: amuleweb-stage1
408 #Now just the targets to map the Commandline Name to the package names
412 ed2k
: amule-ed2k-stage2
415 cas
: amule-cas-stage2
418 wxcas
: amule-wxcas-stage2
421 webserver
: amuleweb-stage2 amule-theme-default-stage2
424 remotegui
: amule-remote-gui-stage2
427 daemon
: amule-daemon-stage2
430 alc
: amule-alc-stage2
433 alcc
: amule-alcc-stage2
436 amulecmd
: amule-cmd-stage2
439 xas
: amule-xas-stage2
442 ed2k-dbg
: amule-ed2k-dbg
445 cas-dbg
: amule-cas-dbg
448 wxcas-dbg
: amule-wxcas-dbg
451 webserver-dbg
: amuleweb-dbg
454 remotegui-dbg
: amule-remote-gui-dbg
457 daemon-dbg
: amule-daemon-dbg
460 alc-dbg
: amule-alc-dbg
463 alcc-dbg
: amule-alcc-dbg
466 amulecmd-dbg
: amule-cmd-dbg
469 #Here come the Targets for the langauge packages
470 i18n-
%: amule-i18n-
% ;
472 amule-i18n-
%: amule-common
476 #They are just metapackages
477 amule-utils
: alcc amulecmd cas
481 amule-utils-gui
: alc remotegui wxcas
485 #These are empty (Space after Semicolon)
486 debug-packages
: amule-dbg ed2k-dbg cas-dbg wxcas-dbg webserver-dbg remotegui-dbg daemon-dbg alc-dbg alcc-dbg amulecmd-dbg
;
487 normal-packages
: amule-utils amule-utils-gui amule ed2k webserver daemon xas
;
488 language-packages
: i18n-ar i18n-ast i18n-bg i18n-ca i18n-cs i18n-da i18n-de i18n-el i18n-en-gb i18n-es i18n-et-ee i18n-eu i18n-fi i18n-fr i18n-gl i18n-he i18n-hr i18n-hu i18n-it-ch i18n-it i18n-ja i18n-ko-kr i18n-lt i18n-nn i18n-nl i18n-pl i18n-pt-br i18n-pt-pt i18n-ru i18n-sl i18n-sq i18n-sv i18n-tr i18n-uk i18n-zh-cn i18n-zh-tw
;
491 #If we build from a svn checkout, we need to generate configure
495 #Now the targets for dpkg-buildpackage
496 binary-indep
: build
install
498 binary-arch
: debug-packages normal-packages language-packages
500 binary
: binary-indep binary-arch
503 cat README.Debian-Packages
506 .PHONY
: build
clean binary-indep binary-arch binary
install debug-packages normal-packages i18n-only language-packages