1 # Maintainer: David Runge <dvzrv@archlinux.org>
4 pkgver=1.1.0.r154.g0acb8ebf
5 _commit=0acb8ebff6e59f8b000da240e11f31ccee9cca72 # current HEAD
7 pkgdesc="A software modular synth"
9 url="https://www.bespokesynth.com/"
38 'jack: to use with JACK'
39 'python-jedi: for code completion'
43 $pkgname::git+https://github.com/$pkgname/$pkgname#commit=$_commit
44 MTS-ESP::git+https://github.com/ODDSound/MTS-ESP
45 $pkgname-1.1.0-devendor_ableton_link.patch
49 '29f6ea325ae9ab974443bfc87ace59a89b18c8ec355224a4d15ad5bda6601c1901381259761f561b96426ab4688680f0409297eb8750b2d6516e6ca49da16f73')
52 'f1d45e9220ec4d33327fb96594b6b3b5db2b4d3fc8716946568fe695de8ad5a8558218f803a9906cb31f955fc3f44ce9fd5265db65a94ea4cd538cb7777c88f4')
56 git describe --exclude Nightly --long --tags | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g'
60 # devendor abletonlink
61 patch -Np1 -d $pkgname -i ../$pkgname-1.1.0-devendor_ableton_link.patch
65 git config submodule.libs/oddsound-mts/MTS-ESP.url "$srcdir/MTS-ESP"
66 # NOTE: use bundled juce as upstream is seemingly not interested in doing releases: https://github.com/BespokeSynth/BespokeSynth/issues/918
67 # git submodule deinit libs/JUCE
68 git submodule deinit libs/pybind11
69 git submodule deinit libs/tuning-library
70 git submodule deinit libs/json/jsoncpp
71 git -c protocol.file.allow=always submodule update
77 -D CMAKE_BUILD_TYPE=None
78 -D CMAKE_INSTALL_PREFIX=/usr
79 -D BESPOKE_DEVENDORED_SYSTEM_JUCE=OFF
80 -D BESPOKE_SYSTEM_ABLETONLINK=ON
81 -D BESPOKE_SYSTEM_PYBIND11=ON
82 -D BESPOKE_SYSTEM_JSONCPP=ON
83 -D BESPOKE_SYSTEM_TUNING_LIBRARY=ON
84 -D BESPOKE_SYSTEM_JUCE=OFF
89 cmake "${cmake_options[@]}"
90 cmake --build build --verbose
94 ctest --test-dir build --output-on-failure
100 freetype2 libfreetype.so
101 jsoncpp libjsoncpp.so
105 DESTDIR="$pkgdir" cmake --install build