archrelease: copy trunk to community-any
[arch-community.git] / cfssl / trunk / PKGBUILD
blobfe16f5eb8be0badd6ccfd04ea3fa5150817c4ef1
1 # Maintainer : Christian Rebischke <chris.rebischke@archlinux.org>
2 # Contributor: Konstantin Gribov <grossws@gmail.com>
4 pkgname=cfssl
5 pkgver=1.6.4
6 pkgrel=1
7 pkgdesc="CloudFlare PKI and TLS toolkit"
8 arch=('i686' 'x86_64')
9 url="https://cfssl.org/"
10 license=('BSD')
11 depends=('glibc')
12 makedepends=('go')
14 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cloudflare/${pkgname}/archive/v${pkgver}.tar.gz")
15 sha256sums=('652b8c50882035e7dc13e937729c84217259838ba80ce089048b96795389482e')
17 _binaries=(cfssl cfssljson cfssl-bundle cfssl-certinfo cfssl-newkey cfssl-scan mkbundle multirootca)
19 build() {
20   cd "${srcdir}/${pkgname}-${pkgver}"
21   make VERSION="${pkgver}-${pkgrel}"
24 package() {
25   cd "${srcdir}/${pkgname}-${pkgver}"
27   for bin in ${_binaries[@]} ; do
28     install -m755 -D -t "${pkgdir}/usr/bin/" bin/${bin}
29   done
31   # special case to avoid clash with `mono`
32   mv ${pkgdir}/usr/bin/mkbundle ${pkgdir}/usr/bin/cfssl-mkbundle
34   install -m644 -D LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
37 # vim: et: sw=2: sts=2: