archrelease: copy trunk to community-any
[arch-community.git] / clxclient / trunk / PKGBUILD
blob2584388c37697494b2fa18689e4181d8af6b83a4
1 # Maintainer: David Runge <dave@sleepmap.de>
2 # Contributor: speps <speps at aur dot archlinux dot org>
3 # Contributor: Christoph Zeiler <rabyte*gmail>
4 # Contributor: Tom K <tomk@runbox.com>
5 # Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
6 # Contributor: Philipp Überbacher <murks at lavabit dot com>
8 pkgname=clxclient
9 pkgver=3.9.2
10 pkgrel=4
11 pkgdesc="C++ wrapper library around the X Window System API"
12 arch=('x86_64')
13 url="https://kokkinizita.linuxaudio.org/linuxaudio/"
14 license=('LGPL2.1')
15 depends=('gcc-libs' 'glibc' 'libx11' 'libxft')
16 makedepends=('clthreads')
17 provides=('libclxclient.so')
18 source=("https://kokkinizita.linuxaudio.org/linuxaudio/downloads/${pkgname}-${pkgver}.tar.bz2")
19 sha512sums=('38c2782e58df24c2dfcb936fc9cfe4d44016055fb1aa52ef8e789bf8ec327f45f2f7a91f18012e4b0c6f253f6f10329d6d1e9fc341017ace3f2b6fa050592049')
21 prepare() {
22   cd "$pkgname-$pkgver"
23   # removing optimization
24   # call ldconfig in local context
25   sed -e '/native/d' \
26       -e 's/ldconfig/& -N $(DESTDIR)\/$(LIBDIR)/' \
27       -i source/Makefile
28   # fix global header include
29   sed -e 's/<clxclient.h>/\"clxclient.h\"/' -i source/enumip.cc
32 build() {
33   cd "${pkgname}-${pkgver}"
34   make -C source
37 package(){
38   cd "${pkgname}-${pkgver}"
39   make DESTDIR="${pkgdir}/" PREFIX='/usr' LIBDIR='/usr/lib' -C source install
40   install -vDm 644 AUTHORS -t "${pkgdir}/usr/share/doc/${pkgname}"