archrelease: copy trunk to community-any
[arch-community.git] / deepin-voice-note / trunk / PKGBUILD
blobdddc3bc3230f501a3883800ef7e10c0cf5478461
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=deepin-voice-note
4 pkgver=5.11.1
5 _commit=b93284dc394afc15bdadea70609eb3128bc0a2fd
6 pkgrel=1
7 pkgdesc='A lightweight memo tool to make text notes and voice recordings'
8 arch=('x86_64')
9 url="https://github.com/linuxdeepin/deepin-voice-note"
10 license=('GPL3')
11 replaces=('deepin-voice-recorder')
12 depends=('deepin-qt5integration' 'deepin-qt-dbus-factory' 'qt5-multimedia' 'qt5-webengine' 'vlc')
13 makedepends=('git' 'cmake' 'gmock' 'gtest' 'ninja' 'qt5-tools')
14 groups=('deepin-extra')
15 source=("git+https://github.com/linuxdeepin/deepin-voice-note.git#commit=$_commit")
16 sha512sums=('SKIP')
18 build() {
19   cd deepin-voice-note
20   cmake -GNinja .
21   ninja
24 check() {
25   cd deepin-voice-note
26   ninja test || :
29 package() {
30   cd deepin-voice-note
31   DESTDIR="$pkgdir" ninja install