archrelease: copy trunk to community-any
[arch-community.git] / drumstick / trunk / PKGBUILD
blob7bc9db9c044d8a35dac4c828abdbf20f9cb2b459
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: speps <speps at aur dot archlinux dot org>
3 # Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
5 pkgname=drumstick
6 pkgver=2.7.2
7 pkgrel=1
8 pkgdesc="MIDI libraries for Qt5/C++"
9 arch=(x86_64)
10 url="https://drumstick.sourceforge.io/"
11 license=(GPL2)
12 depends=(gcc-libs glibc hicolor-icon-theme qt6-base qt6-5compat)
13 makedepends=(alsa-lib cmake doxygen docbook-xsl fluidsynth graphviz libpulse
14 qt6-tools sonivox)
15 provides=(libdrumstick-alsa.so libdrumstick-file.so libdrumstick-rt.so
16 libdrumstick-widgets.so)
17 source=(https://downloads.sourceforge.net/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2)
18 sha512sums=('714a68fc61aa49d4e5b5e4edac4798ab7d8e9b6552c3a7ac5e30fe3cf8206ba8e63628c6dff59d25a15a2afee783b3b621c8069e01296d5cc67e8aec9ed9b68d')
19 b2sums=('080df980de2a2c91de05fe02492b42492583fc4673000c3f925c5b5a6cf64c3fb6b7f463c3ea444633e7107eaf6349459e3cc369f266246505c8bdb9fda71345')
21 build() {
22   cmake -DCMAKE_INSTALL_PREFIX=/usr \
23         -DCMAKE_BUILD_TYPE=None \
24         -Wno-dev \
25         -B build \
26         -S $pkgname-$pkgver
27   make VERBOSE=1 -C build
30 check() {
31   # some tests fail due to insufficient system privileges, hence only run those
32   # that make sense in the build environment
33   # https://sourceforge.net/p/drumstick/bugs/24/
34   make test -C build/tests/fileTest1
35   make test -C build/tests/fileTest2
38 package() {
39   depends+=(libasound.so libfluidsynth.so libpulse.so libpulse-simple.so libsonivox.so)
41   make DESTDIR="$pkgdir" install -C build
42   install -vDm 644 $pkgname-$pkgver/{AUTHORS,ChangeLog,NEWS,readme.md,TODO} -t "$pkgdir/usr/share/doc/$pkgname/"