1 # Contributor: Ronald van Haren <ronald@archlinux.org>
2 # Contributor: Enlightenment Developers <enlightenment-devel@enlightenment.org>
5 pkgname=('efl' 'efl-docs')
8 pkgdesc="Enlightenment Foundation Libraries"
10 url="https://www.enlightenment.org"
11 license=('BSD' 'LGPL2.1' 'GPL2' 'MIT' 'custom')
12 depends=('curl' 'dbus' 'fontconfig' 'freetype2' 'fribidi' 'giflib' 'glib2' 'gstreamer'
13 'gst-plugins-base-libs' 'harfbuzz' 'hicolor-icon-theme' 'libglvnd' 'libinput'
14 'libjpeg-turbo' 'libpng' 'libpulse' 'libsndfile' 'libtiff' 'libunwind' 'libwebp' 'libx11'
15 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi'
16 'libxinerama' 'libxkbcommon' 'libxkbcommon-x11' 'libxrandr' 'libxrender' 'libxss'
17 'libxtst' 'lua52' 'mailcap' 'mesa' 'openjpeg2' 'openssl' 'shared-mime-info' 'systemd-libs'
18 'ttf-font' 'util-linux-libs' 'wayland' 'zlib')
19 optdepends=('gst-plugins-base: Video and thumbnail codecs'
20 'gst-plugins-good: Video and thumbnail codecs'
21 'gst-plugins-bad: Video and thumbnail codecs'
22 'gst-plugins-ugly: Video and thumbnail codecs'
23 'gst-libav: Video and thumbnails with ffmpeg/libav'
24 'libraw: RAW image loader'
25 'libreoffice: Office document loader'
27 'libspectre: PostScript loader'
29 'scim: IM module for SCIM')
30 makedepends=('doxygen' 'libraw' 'librsvg' 'libspectre' 'meson' 'ninja' 'poppler' 'python' 'scim'
31 'texlive-core' 'wayland-protocols')
32 options=('!emptydirs')
33 source=(https://download.enlightenment.org/rel/libs/${pkgname}/$pkgname-$pkgver.tar.xz)
34 sha256sums=('d9f83aa0fd9334f44deeb4e4952dc0e5144683afac786feebce6030951617d15')
38 cd "${srcdir}/${pkgname}-${pkgver}"
40 export CFLAGS="$CFLAGS -fvisibility=hidden"
51 -Dnetwork-backend=connman \
52 -Dlua-interpreter=lua \
54 -Dbuild-examples=false \
65 replaces=('elementary' 'evas_generic_loaders' 'emotion_generic_players')
67 cd "${srcdir}/${pkgname}-${pkgver}"
68 DESTDIR="${pkgdir}" ninja -C build install
70 # install non-standard license files
71 install -Dm644 "${srcdir}/${pkgname}-${pkgver}/licenses/COPYING.BSD" \
72 "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.BSD"
73 install -Dm644 "${srcdir}/${pkgname}-${pkgver}/licenses/COPYING.SMALL" \
74 "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.SMALL"
78 pkgdesc="Documentation for the Enlightenment Foundation Libraries"
81 cd "${srcdir}/${pkgbase}-${pkgver}/build"
82 install -d "${pkgdir}/usr/share/doc/${pkgbase}"
83 cp -a html "${pkgdir}/usr/share/doc/${pkgbase}/html"
84 cp -a latex "${pkgdir}/usr/share/doc/${pkgbase}/latex"
85 #cp -a man "${pkgdir}/usr/share"