archrelease: copy trunk to community-any
[arch-community.git] / ext4magic / trunk / PKGBUILD
blob1233c537f3af2211aaf669cda505ada907200783
1 # Maintainer: Sébastien Luttringer
3 pkgname=ext4magic
4 pkgver=0.3.2
5 pkgrel=4
6 pkgdesc='Recover deleted or overwritten files on ext3 and ext4 filesystems'
7 arch=('x86_64')
8 url='https://sourceforge.net/projects/ext4magic/'
9 license=('GPL2')
10 depends=('bzip2' 'file' 'util-linux' 'e2fsprogs')
11 source=("$url/files/$pkgname-$pkgver.tar.gz"
12         "$url/files/Patches/workaround.patch"
13         '01-i_dir_acl.patch'
14         '02-Fix-undefined-reference-to-makedev.patch')
15 sha256sums=('8d9c6a594f212aecf4eb5410d277caeaea3adc03d35378257dfd017ef20ea115'
16             '89468a7857778bd171490cddfc1f4ce8b8308c46353e8c01998dc054373f5fff'
17             '2b5cde2612370f49fa9ed8442c23425499bdcf67aaba442087eb11f1c8b51e06'
18             '850378bcee22c9e4888c7ebb77085db29747383e5a272795be18341d4426f2db')
20 prepare() {
21   cd $pkgname-$pkgver
22   # apply patch from the source array (should be a pacman feature)
23   local filename
24   for filename in "${source[@]}"; do
25     if [[ "$filename" =~ \.patch$ ]]; then
26       echo "Applying patch ${filename##*/}"
27       patch -p1 -N -i "$srcdir/${filename##*/}"
28     fi
29   done
30   :
33 build() {
34   cd $pkgname-$pkgver
35   ./configure --prefix=/usr --sbindir=/usr/bin
36   make
39 package() {
40   cd $pkgname-$pkgver
41   make DESTDIR="$pkgdir" install
44 # vim:set ts=2 sw=2 et: