archrelease: copy trunk to community-any
[arch-community.git] / gwenhywfar / trunk / PKGBUILD
blob7ae0d1071f7b2586901ce89db0d3b08688d1b857
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
4 # Contributor: William Rea <sillywilly@gmail.com>
6 pkgname=gwenhywfar
7 pkgver=5.10.1
8 pkgrel=1
9 pkgdesc="OS abstraction functions for various projects"
10 arch=('x86_64')
11 url="https://www.aquamaniac.de/"
12 license=('LGPL')
13 depends=('gnutls' 'libgcrypt' 'openssl')
14 makedepends=('git' 'gtk3' 'qt5-base')
15 optdepends=('gtk3: for the GTK3 UI'
16             'qt5-base: for the Qt5 UI')
17 source=(https://www.aquamaniac.de/rdm/attachments/download/465/$pkgname-$pkgver.tar.gz
18         https://www.aquamaniac.de/rdm/attachments/download/464/$pkgname-$pkgver.tar.gz.asc)
19 sha256sums=('a2f60a9dde5da27e57e0e5ef5f8931f495c1d541ad90a841e2b6231565547160'
20             'SKIP')
21 validpgpkeys=(42400AF5EB2A17F0A69BB551E9899D784A977416) # AqBanking Package Key <packages@aqbanking.de>
23 build() {
24   cd $pkgname-$pkgver
25   ./configure --prefix=/usr --sysconfdir=/etc --enable-system-certs --with-guis="gtk3 qt5"
26   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
27   make
30 package() {
31   cd $pkgname-$pkgver
32   make DESTDIR="${pkgdir}" install