archrelease: copy trunk to community-any
[arch-community.git] / haskell-data-accessor / trunk / PKGBUILD
blob3552755044fcabc5fa44dbf453fce64eacd02076
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=data-accessor
5 pkgname=haskell-data-accessor
6 pkgver=0.2.3.1
7 pkgrel=1
8 pkgdesc="Utilities for accessing and manipulating fields of records"
9 url="http://www.haskell.org/haskellwiki/Record_access"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('bd487d74fa7c3d208519eb13b7d2abaa5e27ccccd154b5073580579dafc62b74bbba238ac8d6f21ecadef2aef46aa1f19da59e437bbd6535aa5dd2011b27a9af')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23             -fsplitbase -fcategory
24     runhaskell Setup build $MAKEFLAGS
25     runhaskell Setup register --gen-script
26     runhaskell Setup unregister --gen-script
27     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 package() {
32     cd $_hkgname-$pkgver
33     
34     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
35     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
36     runhaskell Setup copy --destdir="$pkgdir"
37     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
38     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE