archrelease: copy trunk to community-any
[arch-community.git] / haskell-fast-logger / repos / community-x86_64 / PKGBUILD
blob11264a7184ddc199a6fb71ba50e31f5c6b6e1e53
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=fast-logger
5 pkgname=haskell-fast-logger
6 pkgver=3.1.2
7 pkgrel=18
8 pkgdesc="A fast logging system"
9 url="https://github.com/kazu-yamamoto/logger"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-auto-update' 'haskell-easy-file' 'haskell-unix-compat'
13          'haskell-unix-time')
14 makedepends=('ghc' 'haskell-hspec' 'haskell-hspec-discover')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('fe034662f090a761bcc79f9a2fbaafc90828f162f2d13a865030b52699ba8a8eadf78afbeb95c6ae7c81dd7685f0de3efb358e90f2ad493aff11e7fdf42f826d')
18 build() {
19     cd $_hkgname-$pkgver
20     
21     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
23         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
24     runhaskell Setup build $MAKEFLAGS
25     runhaskell Setup register --gen-script
26     runhaskell Setup unregister --gen-script
27     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 check() {
32     cd $_hkgname-$pkgver
33     runhaskell Setup test --show-details=direct
36 package() {
37     cd $_hkgname-$pkgver
38     
39     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
40     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
41     runhaskell Setup copy --destdir="$pkgdir"
42     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
43     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE