archrelease: copy trunk to community-any
[arch-community.git] / haskell-ghc-bignum-orphans / trunk / PKGBUILD
blob07f3489843ae13535c044bc015af463c73f22105
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ghc-bignum-orphans
4 pkgname=haskell-ghc-bignum-orphans
5 pkgver=0.1.1
6 pkgrel=1
7 pkgdesc="Backwards-compatible orphan instances for ghc-bignum"
8 url="https://github.com/haskell-compat/ghc-bignum-orphans"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('a4c617c7b90288ba3e24c67633f99e97e11c2367686463b8884d2cd3591241db')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie'
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 package() {
33   cd $_hkgname-$pkgver
35   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
36   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
37   runhaskell Setup copy --destdir="$pkgdir"