archrelease: copy trunk to community-any
[arch-community.git] / haskell-gi-gdk3 / trunk / PKGBUILD
blob880f74eb99c9f7365cd69a367850e58e97bfae89
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=gi-gdk
4 pkgname=haskell-gi-gdk3
5 pkgver=3.0.25
6 pkgrel=68
7 pkgdesc="Gdk bindings (GTK3)"
8 url="https://github.com/haskell-gi/haskell-gi"
9 license=("LGPL2.1")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-gi-cairo' 'haskell-gi-gdkpixbuf' 'haskell-gi-gio' 'haskell-gi-glib'
12          'haskell-gi-gobject' 'haskell-gi-pango' 'haskell-gi' 'haskell-gi-base'
13          'haskell-gi-overloading' 'gtk3')
14 makedepends=('ghc' 'gobject-introspection')
15 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
16 sha256sums=('ddf6ed6379734bd42dd62c4758a5c504316d6fda0eb185ef28d769ac4fd58fba')
18 build() {
19   cd $_hkgname-$pkgver
21   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
23     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
24     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
25     --ghc-option='-pie' 
27   runhaskell Setup build $MAKEFLAGS
28   runhaskell Setup register --gen-script
29   runhaskell Setup unregister --gen-script
30   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35   cd $_hkgname-$pkgver
36   runhaskell Setup test --show-details=direct
39 package() {
40   cd $_hkgname-$pkgver
42   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44   runhaskell Setup copy --destdir="$pkgdir"
45   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
46   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE