archrelease: copy trunk to community-any
[arch-community.git] / haskell-gi-xlib / trunk / PKGBUILD
blob02b8f6e4bbbc33d1d95e01361660bc085e941337
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=gi-xlib
4 pkgname=haskell-gi-xlib
5 pkgver=2.0.12
6 pkgrel=39
7 pkgdesc="xlib bindings"
8 url="https://github.com/haskell-gi/haskell-gi"
9 license=("LGPL2.1")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-gi' 'haskell-gi-base' 'haskell-gi-overloading' 'libx11')
12 makedepends=('ghc' 'gobject-introspection')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('f2816392f332ffc46918ffe7c18e03ae71cb54f8b58223a43dd04fb8beebc137')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie' 
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33   cd $_hkgname-$pkgver
34   runhaskell Setup test --show-details=direct
37 package() {
38   cd $_hkgname-$pkgver
40   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42   runhaskell Setup copy --destdir="$pkgdir"
43   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
44   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE