1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Daniel Nagy <danielnagy at gmx de>
5 pkgname=haskell-http-types
8 pkgdesc="Generic HTTP types for Haskell (for both client and server code)."
9 url="https://hackage.haskell.org/package/${_hkgname}"
12 depends=('ghc-libs' 'haskell-case-insensitive')
13 makedepends=('ghc' 'haskell-doctest' 'haskell-hspec' 'haskell-quickcheck'
14 'haskell-quickcheck-instances')
15 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
16 sha512sums=('fdaf95cfd29ed47445af4ad6349fcbbf4dcd8341f3963da453f8be5eccae4757904d3c4e7a8719ab576a7e7857aaa035ecfc1aa8f99f4ec6fce950c7ccc76597')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid -fnetwork-uri
23 runhaskell Setup build $MAKEFLAGS
24 runhaskell Setup register --gen-script
25 runhaskell Setup unregister --gen-script
26 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 runhaskell Setup test --show-details=direct
38 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40 runhaskell Setup copy --destdir="$pkgdir"
41 install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
42 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE