archrelease: copy trunk to community-any
[arch-community.git] / haskell-language-c / repos / community-x86_64 / PKGBUILD
blobb0d118a9f513b85f408ddcbe9e99c43c30baa1d6
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=language-c
5 pkgname=haskell-language-c
6 pkgver=0.9.2
7 pkgrel=1
8 pkgdesc="Analysis and generation of C code"
9 url="https://visq.github.io/language-c/"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs')
13 makedepends=('alex' 'happy' 'ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('eaa1a0befbc6ccb5ed53a200a03ea7fa51c2d820fb501476576cc4268d8c8816080f942a5044a769e88a1ec58b0f3f5ca55512c70b797a6c3555186e842de701')
17 build() {
18     cd $_hkgname-$pkgver
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23             -fseparatesyb -fusebytestrings -f-allwarnings -fiecfpextension
24     runhaskell Setup build $MAKEFLAGS
25     runhaskell Setup register --gen-script
26     runhaskell Setup unregister --gen-script
27     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 check() {
32     cd $_hkgname-$pkgver
33     runhaskell Setup test --show-details=direct
36 package() {
37     cd $_hkgname-$pkgver
39     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
40     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
41     runhaskell Setup copy --destdir="$pkgdir"
42     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
43     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE