archrelease: copy trunk to community-any
[arch-community.git] / haskell-nettle / trunk / PKGBUILD
blob78b29f76743e2bb78b36d77bf9d863d4055fa342
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=nettle
4 pkgname=haskell-nettle
5 pkgver=0.3.0
6 pkgrel=252
7 pkgdesc="Safe nettle binding"
8 url="https://github.com/stbuehler/haskell-nettle"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'nettle' 'haskell-byteable' 'haskell-crypto-cipher-types' 'haskell-tagged'
12          'haskell-securemem')
13 makedepends=('ghc')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('9bc875c0674ea615f47c498bd40fcbd8ffb356e99b30bde6b0e350a9dcfed353bc21242ea625cecc23b16b617f1e163dab42740cadc49ac5c73f161fd0898ac7')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 package() {
31     cd $_hkgname-$pkgver
32     
33     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35     runhaskell Setup copy --destdir="$pkgdir"
36     install -D -m644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
37     rm -f "${pkgdir}/usr/share/doc/${pkgname}/COPYING"