1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=singleton-bool
4 pkgname=haskell-singleton-bool
7 pkgdesc="Type level booleans"
8 url="https://github.com/phadej/singleton-bool"
11 depends=('ghc-libs' 'haskell-boring' 'haskell-dec' 'haskell-some')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('7f14909f672aa18e0c2064fb735f894a01d5a450e6fc7a6ac28fa5cc7dd1fb2ea1a5a58a0654a98d79aae49a4c537ace5d5f6eb30e68fe0e69e0992e7e510b86')
19 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
21 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22 runhaskell Setup build $MAKEFLAGS
23 runhaskell Setup register --gen-script
24 runhaskell Setup unregister --gen-script
25 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
33 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
34 runhaskell Setup copy --destdir="$pkgdir"
35 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
36 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE