archrelease: copy trunk to community-any
[arch-community.git] / haskell-stm-containers / trunk / PKGBUILD
blob0966be36267279391d663add7c8a90f5b1de73b2
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=stm-containers
4 pkgname=haskell-stm-containers
5 pkgver=1.2
6 pkgrel=47
7 pkgdesc="Containers for STM"
8 url="https://github.com/nikita-volkov/stm-containers"
9 license=("MIT")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-deferred-folds' 'haskell-focus' 'haskell-hashable' 'haskell-list-t'
12          'haskell-stm-hamt')
13 makedepends=('ghc' 'uusi' 'haskell-htf' 'haskell-quickcheck' 'haskell-foldl' 'haskell-free'
14              'haskell-quickcheck-text' 'haskell-rerebase')
15 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
16 sha256sums=('6c4d98b6a3182fa0dd99235cea1aa95a3c876f8be5cbb78f7700a17d64b7177a')
18 prepare() {
19   cd $_hkgname-$pkgver
20   uusi -u HTF $_hkgname.cabal
23 build() {
24   cd $_hkgname-$pkgver
26   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
28     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
29     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
30     --ghc-option='-pie' 
32   runhaskell Setup build $MAKEFLAGS
33   runhaskell Setup register --gen-script
34   runhaskell Setup unregister --gen-script
35   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
36   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
39 check() {
40   cd $_hkgname-$pkgver
41   runhaskell Setup test --show-details=direct
44 package() {
45   cd $_hkgname-$pkgver
47   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
48   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
49   runhaskell Setup copy --destdir="$pkgdir"
50   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
51   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE