1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=vector-hashtables
4 pkgname=haskell-vector-hashtables
7 pkgdesc="Efficient vector-based mutable hashtables implementation."
8 url="https://github.com/klapaucius/vector-hashtables#readme"
11 depends=('ghc-libs' 'haskell-hashable' 'haskell-primitive' 'haskell-vector')
12 makedepends=('ghc' 'haskell-quickcheck' 'haskell-hspec' 'haskell-hspec-discover'
13 'haskell-quickcheck-instances')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('662fc65641871dcbc324db3cf055f2f3482520451a74276b37e307ceb63e2342')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
26 runhaskell Setup build $MAKEFLAGS
27 runhaskell Setup register --gen-script
28 runhaskell Setup unregister --gen-script
29 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 runhaskell Setup test --show-details=direct
41 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43 runhaskell Setup copy --destdir="$pkgdir"
44 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
45 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE