archrelease: copy trunk to community-any
[arch-community.git] / hatari / trunk / PKGBUILD
blob5b2910f71ae5ad2397cd9af8327a7e75d7bdc9f2
1 # Maintainer: Laurent Carlier <lordheavy@archlinux.org>
2 # Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
4 pkgname=hatari
5 pkgver=2.4.1
6 pkgrel=2
7 pkgdesc='An Atari ST and STE emulator'
8 arch=('x86_64')
9 url='http://hatari.sourceforge.net/'
10 license=('GPL')
11 depends=(
12   'glibc'
13   'hicolor-icon-theme'
14   'sdl2'
15   'libpng'
16   'libx11'
17   'portmidi'
18   'readline'
19   'systemd-libs'
20   'zlib'
22 makedepends=('cmake' 'systemd')
23 optdepends=(
24   'python: for atari-convert-dir'
25   'sh: for atari-hd-image, zip2st, hatari-prg-args'
27 source=("https://download.tuxfamily.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
28 sha256sums=('2a5da1932804167141de4bee6c1c5d8d53030260fe7fe7e31e5e71a4c00e0547')
30 build() {
31   cd ${pkgname}-${pkgver}
33   ./configure --prefix=/usr
35   make
38 package() {
39   cd ${pkgname}-${pkgver}
41   make DESTDIR="${pkgdir}" install