1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Contributor: ThatOneCalculator <kainoa@t1c.dev>
7 pkgdesc='a highly customizable dynamic tiling Wayland compositor'
9 url="https://github.com/hyprwm/${pkgname^}"
34 vulkan-validation-layers
45 depends+=(libdisplay-info.so)
52 _archive="${pkgname^}-$pkgver"
53 source=("$_archive.tar.gz::$url/releases/download/v$pkgver/source-v$pkgver.tar.gz")
54 sha256sums=('c91029085daa80437b1ef5ac10cd849795a8ce32d36663eff949af5f9337217b')
57 ln -sf hyprland-source "$_archive"
60 sed -i -e '/^release:/{n;s/-D/-DCMAKE_SKIP_RPATH=ON -D/}' Makefile
61 # https://github.com/hyprwm/Hyprland/issues/2226
62 sed -i -e 's/\(.*GIT_COMMIT_HASH \)\(.*\)/\1"\2"/' src/defines.hpp
67 pushd subprojects/wlroots
68 meson build/ --prefix="$srcdir/tmpwlr" --buildtype=release
70 mkdir -p "$srcdir/tmpwlr"
71 ninja -C build/ install
73 pushd subprojects/udis86
74 cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=Release -H./ -B./build -G Ninja
75 cmake --build ./build --config Release --target all
85 install -Dm0755 -t "$pkgdir/usr/bin" build/Hyprland
86 install -Dm0755 -t "$pkgdir/usr/bin" hyprctl/hyprctl
87 install -Dm0644 -t "$pkgdir/usr/share/$pkgname" assets/*.png
88 install -Dm0644 -t "$pkgdir/usr/share/wayland-sessions" "example/$pkgname.desktop"
89 install -Dm0644 -t "$pkgdir/usr/share/$pkgname" "example/$pkgname.conf"
90 install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
91 install -Dm0755 -t "$pkgdir/usr/lib" "$srcdir/tmpwlr/lib/libwlroots.so.12032"