archrelease: copy trunk to community-any
[arch-community.git] / interception-caps2esc / repos / community-x86_64 / PKGBUILD
blob5b94df80e3571f1f277bc7194058a4107b677624
1 # Maintainer: Brett Cornwall <ainola@archlinux.org>
2 # Contributor: Francisco Lopes
4 pkgname=interception-caps2esc
5 pkgver=0.3.2
6 pkgrel=2
7 pkgdesc='Interception plugin that transforms the most useless key ever in the most useful one'
8 arch=('x86_64')
9 license=('MIT')
10 url='https://gitlab.com/interception/linux/plugins/caps2esc'
11 depends=('interception-tools')
12 makedepends=('cmake')
13 source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/interception/linux/plugins/caps2esc/-/archive/v$pkgver/caps2esc-v$pkgver.tar.gz")
14 sha256sums=('d8a5c7a23cb7368fde2b91a0b5481d8ce906af146dd9a49f609052f2cf1d212c')
16 build() {
17     cmake -B build \
18           -S "caps2esc-v${pkgver}" \
19           -DCMAKE_INSTALL_PREFIX=/usr \
20           -DCMAKE_BUILD_TYPE=None \
21           -Wno-dev
22     cmake --build build
25 package() {
26     install -Dm644 "caps2esc-v${pkgver}/README.md" -t "$pkgdir/usr/share/doc/$pkgname"
27     install -Dm644 "caps2esc-v${pkgver}/LICENSE.md" -t "$pkgdir/usr/share/licenses/$pkgname"
29     cd build
30     make DESTDIR="$pkgdir/" install