1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Kyle Keen <keenerd@gmail.com>
4 pkgname=jupyter-nbclient
7 pkgdesc='A tool for running Jupyter Notebooks in different execution contexts'
9 url='https://github.com/jupyter/nbclient'
11 depends=(python-traitlets python-jupyter-client jupyter-nbformat python-testpath)
12 makedepends=(python-build python-installer python-hatchling)
13 checkdepends=(python-pytest-asyncio python-xmltodict jupyter-nbconvert python-ipywidgets python-flaky)
14 source=(https://github.com/jupyter/nbclient/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('faa17a5253d6e8ec0db50a0dbe520899cb6840b3908112cba9462cc9b0cc21e2')
19 python -m build --wheel --no-isolation
29 python -m installer --destdir="$pkgdir" dist/*.whl
31 install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"