archrelease: copy trunk to community-any
[arch-community.git] / jupyter-nbclient / trunk / PKGBUILD
blobf9c2a59d55e8efbd8a87cbd1b7ae2c50bd0ac93d
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Kyle Keen <keenerd@gmail.com>
4 pkgname=jupyter-nbclient
5 pkgver=0.7.4
6 pkgrel=2
7 pkgdesc='A tool for running Jupyter Notebooks in different execution contexts'
8 arch=(any)
9 url='https://github.com/jupyter/nbclient'
10 license=(BSD)
11 depends=(python-traitlets python-jupyter-client jupyter-nbformat python-testpath)
12 makedepends=(python-build python-installer python-hatchling)
13 checkdepends=(python-pytest-asyncio python-xmltodict jupyter-nbconvert python-ipywidgets python-flaky)
14 source=(https://github.com/jupyter/nbclient/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('faa17a5253d6e8ec0db50a0dbe520899cb6840b3908112cba9462cc9b0cc21e2')
17 build() {
18   cd nbclient-$pkgver
19   python -m build --wheel --no-isolation
22 check() {
23   cd nbclient-$pkgver
24   pytest -v
27 package() {
28   cd nbclient-$pkgver
29   python -m installer --destdir="$pkgdir" dist/*.whl
31   install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"