archrelease: copy trunk to community-any
[arch-community.git] / libewf / trunk / PKGBUILD
blob534166a7bc62bf4dea4f6a81b163c460bf120123
1 # Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
2 # Contributor: kfgz <kfgz at interia pl>
3 # Contributor: Adam Wolk <netprobe at gmail dot com>
5 pkgname=libewf
6 pkgver=20140608
7 pkgrel=6
8 pkgdesc="A library for support of the Expert Witness Compression Format (EWF)"
9 arch=('x86_64')
10 url="https://github.com/libyal/libewf/"
11 license=('LGPL3')
12 makedepends=('fuse2')
13 depends=('util-linux' 'zlib' 'bzip2')
14 optdepends=('fuse2: to be able to use ewfmount')
15 source=(https://pkgs.fedoraproject.org/repo/pkgs/libewf/libewf-20140608.tar.gz/fdf615f23937fad8e02b60b9e3e5fb35/libewf-20140608.tar.gz)
16 sha256sums=('d14030ce6122727935fbd676d0876808da1e112721f3cb108564a4d9bf73da71')
18 build() {
19   cd "${srcdir}"/$pkgname-$pkgver
21   CPPFLAGS="$CPPFLAGS -std=gnu89"
22   ./configure --prefix=/usr --sysconfdir=/etc --without-openssl
23   make
26 package() {
27   cd "${srcdir}"/$pkgname-$pkgver
29   make DESTDIR="${pkgdir}" install